Dutch Language on ISPconfig Ubuntu 8.04

Discussion in 'Installation/Configuration' started by raymonvdm, Nov 25, 2008.

  1. raymonvdm

    raymonvdm New Member


    Last week i reinstalled mij server from BleuQuartz tot Ubuntu 8.04 with
    ISPConfig Version: 2.2.27
    GetText Support enabled

    Now im trying to get my sites live one by one because all have some kind of error.

    The first problem:

    Im a dutch speaking person and so are my webmail users. But i cannot figure out how to get squirellmail to the dutch language settings. When testing on mij Debian/Apache2 server al i need tot do is add "AddLanguage nl nl" to the vhost config. But when i do this on my ISPconfig machine it doesnt work.

    I cannot find any errors. Im having the same issues on mij ampache vhost (www.ampache.org) Which on my debian/apache is also working correctly

    On mij gallery V1 website i got the same issue

    I just added AddLanguage nl nl to the Apache Directives
    Last edited: Nov 26, 2008
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please take a look at the apache2.conf file and set the appropriate default charset for your language.
  3. raymonvdm

    raymonvdm New Member

    I think you mean the config file


    There is no charset setting in /etc/apache2/apache2.conf

    So i uncommented #AddDefaultCharset UTF-8 in /etc/apache2/conf.2/charset but this doenst make a difference.(did an apache stop/start) On the Debian 4 / Apache2 server this is a default setting. But on ISPconfig the websites are still english en no dutch.

    When i add

    AddCharset ISO-8859-1 .iso8859-1 .latin1
    AddCharset UTF-8 .utf8
    AddDefaultCharset ISO-8859-1
    AddDefaultCharset UTF-8

    Or a various combination of these settings to /etc/apache2/conf.2/charset. All with no luck

    Can somebody please help me :-(
    Last edited: Nov 26, 2008
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    You can add just one default charset. The default charset for western languages is:

    AddDefaultCharset ISO-8859-1
  5. raymonvdm

    raymonvdm New Member

    Its not working :-(

    I added the AddDefaultCharset ISO-8859-1 to the /etc/apache2/apache2.conf

    Later i added AddDefaultCharset ISO-8859-1 tot het apache directives

    Still no luck
  6. falko

    falko Super Moderator ISPConfig Developer

    If you installed the SquirrelMail webmail package from ISPConfig, then the configuration file is /root/ispconfig/httpd/conf/httpd.conf.
  7. raymonvdm

    raymonvdm New Member

    I did install this package, but am using the downloaded version on de different domein.

    But i wil test the language funcition on the package version aswel. Just to see wat happens
  8. raymonvdm

    raymonvdm New Member

    I still cannot get this to work. When i tar the complete squirrel installation en upload it to a debian 4 server. The language setting in squirrel is working fine(Dutch,German,Englisch) al whitout problem

    So it has something todo with ubuntu 8.04 or with ispconfig.

    What can i try next ?
  9. raymonvdm

    raymonvdm New Member


    vim /var/lib/locales/supported.d/local

    nl_NL.ISO-8859-1 ISO-8859-1 <-- added this rule
    en_US.UTF-8 UTF-8

    dpkg-reconfigure locales

    If all goes well than squirrel should be dutch now, or german what ever you select on the user preferences. Although on gallery V2 and Ampache V3 not all language is translated to dutch.

Share This Page