Duplicate virtual hosts

Discussion in 'General' started by bosei, Sep 22, 2005.

  1. bosei

    bosei New Member

    When I look at apache virtual hosts in webmin I see duplicated virtualhosts. Is this correct or is ISPC somehow re-creating hosts each time I make an amendment? I have screenshots in .png format but they are too large to attache here so I will mail them to Falko and Till.

    Thanks for any forthcoming solution.

    Bosei
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What do you mean with duplicate virtual hosts? What does webmin say? I didn't receive a mail from you...
     
    Last edited: Sep 22, 2005
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    I've had a look at your screenshot and there are no duplicates in ISPConfig.

    One question. Was your Linux system empty (fresh install) as you installed ISPConfig or had you already hosted some websites on this server before you installed ISPConfig and these sites show now up as duplicates?
     
  4. Ovidiu

    Ovidiu Active Member

    I know what he means, recently I had a direct look into my apache configfiles I guess it was vhosts.conf or so and there where duplicate lines (entries) like:

    <virtualhost:xx.xx.xx.xx:80>
    <virtualhost:xx.xx.xx.xx:80>

    just two identical lines of code, I also found duplicate Listen xx.xx.xx.xx 80 Listen xx.xx.xx.xx 80 lines or was it Port 80 Port 80?

    I did not think much about that I just deleted one of every duplicate ;-))

    I thought those entries senseless and anyway I was installing on a test machine
     
  5. linuxfast

    linuxfast New Member

    Just checked all my conf files for duplicate lines, and didn't find any.
     
  6. Ovidiu

    Ovidiu Active Member

    maybe bosei andme both didthe same thingwrong ;-))
     
  7. Ovidiu

    Ovidiu Active Member

    I just found this line
    twice in my /etc/apache2/vhosts/Vhosts_ispconfig.conf

    left it there as I don't know where it comes from...
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Maybe you entered the IP twice in the management part of ISPConfig?
     
  9. Ovidiu

    Ovidiu Active Member

    ahh, thats it I wasn't sure if I am supposed to enter the IP from above in the list below too. seems only additional adresses get in there, thx ;-)
     
  10. bosei

    bosei New Member


    When I recently upgraded ISPConfig. This confirms my suspicion and the problem first happened after a previous re-install. Please see below:

    Creating new config (0x81b0d78) for (null)
    Getting register_globals=1 for 0x81b0d78 (0)
    Getting safe_mode=0 for 0x81b0d78 (1)
    Merge dir (0x80f3758) (0x81b0d78)
    Merge dir (0x80f3758) (0x81ae818)
    Merge dir (0x80f3758) (0x81ad1b8)
    Merge dir (0x80f3758) (0x81aab80)
    Merge dir (0x80f3758) (0x81a37e8)
    Merge dir (0x80f3758) (0x81a11a0)
    Merge dir (0x80f3758) (0x819fe28)
    Merge dir (0x80f3758) (0x819d718)
    [Tue Nov 22 01:02:46 2005] [warn] VirtualHost 192.168.1.5:443 overlaps with VirtualHost 19 2.168.1.5:443, the first has precedence, perhaps you need a NameVirtualHost directive
    [Tue Nov 22 01:02:46 2005] [warn] VirtualHost 192.168.1.10:443 overlaps with VirtualHost 1 92.168.1.10:443, the first has precedence, perhaps you need a NameVirtualHost directive
    [Tue Nov 22 01:02:46 2005] [warn] NameVirtualHost 192.168.1.10:80 has no VirtualHosts
    [Tue Nov 22 01:02:46 2005] [warn] NameVirtualHost 192.168.1.5:80 has no VirtualHosts
    Destroying config 0x81b0d78
    ................................................................................................

    Also, see entries in webmin (converted to text as screenshot file too large to post here) below:

    Virtual Servers

    Default Server Defines the default settings for all other virtual servers, and processes any unhandled requests.

    Address Any
    Port Any Server Name ex01.xconsultants.ltd
    Document Root /srv/www/htdocs
    Virtual Server Handles all requests to the address 192.168.1.10 on port 80.

    Address 192.168.1.10
    Port 80 Server Name www.someaccess.com:80
    Document Root /srv/www/web6/web
    Virtual Server Handles all requests to the address 192.168.1.10 on port 443.

    Address 192.168.1.10
    Port 443 Server Name www.someaccess.com:443
    Document Root /srv/www/web6/web
    Virtual Server Handles all requests to the address 192.168.1.5 on port 80.

    Address 192.168.1.5
    Port 80 Server Name www.xconsultants.ltd:80
    Document Root /srv/www/web7/web
    Virtual Server Handles all requests to the address 192.168.1.5 on port 443.

    Address 192.168.1.5
    Port 443 Server Name www.xconsultants.ltd:443
    Document Root /srv/www/web7/web
    Virtual Server Handles all requests to the address 192.168.1.10 on port 80.

    Address 192.168.1.10
    Port 80 Server Name www.someaccess.com:80
    Document Root /srv/www/web6/web
    Virtual Server Handles all requests to the address 192.168.1.10 on port 443.

    Address 192.168.1.10
    Port 443 Server Name www.someaccess.com:443
    Document Root /srv/www/web6/web
    Virtual Server Handles all requests to the address 192.168.1.5 on port 80.

    Address 192.168.1.5
    Port 80 Server Name www.xconsultants.ltd:80
    Document Root /srv/www/web7/web
    Virtual Server Handles all requests to the address 192.168.1.5 on port 443.

    Address 192.168.1.5
    Port 443 Server Name www.xconsultants.ltdk:443
    Document Root /srv/www/web7/web
     
    Last edited: Nov 22, 2005
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Please have a look at Management > Server > Settings if the IP appears there two times (in the upper part of the form and in the IP list).
     
  12. falko

    falko Super Moderator ISPConfig Developer

    Please have a look at your httpd.conf, apache2.conf, whatever, if the following section appaears twice:

    Code:
    ###############ispconfig_log###############
    LogFormat "%v||||%b||||%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined_ispconfig
    CustomLog "|/root/ispconfig/cronolog --symlink=/var/log/httpd/ispconfig_access_log /var/log/httpd/ispconfig_access_log_%Y_%m_%d" combined_ispconfig
    
    <Directory /var/www/*/web>
        Options +Includes -Indexes
        AllowOverride None
        AllowOverride Indexes AuthConfig Limit FileInfo
        Order allow,deny
        Allow from all
        <Files ~ "^\.ht">
        Deny from all
        </Files>
    </Directory>
    
    <Directory /var/www/*/user/*/web>
        Options +Includes -Indexes
        AllowOverride None
        AllowOverride Indexes AuthConfig Limit FileInfo
        Order allow,deny
        Allow from all
        <Files ~ "^\.ht">
        Deny from all
        </Files>
    </Directory>
    
    <Directory /var/www/*/cgi-bin>
        Options ExecCGI -Indexes
        AllowOverride None
        AllowOverride Indexes AuthConfig Limit FileInfo
        Order allow,deny
        Allow from all
        <Files ~ "^\.ht">
        Deny from all
        </Files>
    </Directory>
    
    Include /etc/apache/vhosts/Vhosts_ispconfig.conf
    (The code does not have to be the same, but similar on your system.) If so, remove the second one and restart Apache.
     
  13. bosei

    bosei New Member

    Have re-installed on a new hosted server and I still seem to have two entries for every site e.g. 2x port:80 and 2x port:443

    It all seems to be working fine though so in the absence of a solution I will leave well enough alone.

    Thanks
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    Have you entered the IP address twice in ISPConfig, under Management > Server > settings? When the IP is in the IP-Address field, it must neot be listed in the IP list field too.
     

Share This Page