du -s on NFS store OOM errors

Discussion in 'Installation/Configuration' started by lee.veal, Apr 4, 2013.

  1. lee.veal

    lee.veal Member

    Hello All,

    We recently upgraded our server cluster from to, system stalls with OOM errors logged to dmesg. Killing off the du process's returns the server back to normal.

    [ 1926.521367] Out of memory: Kill process 11106 (du) score 768 or sacrifice child
    [ 1926.523594] Killed process 11106 (du) total-vm:9882896kB, anon-rss:7644924kB, file-rss:4kB

    [13893.339418] Out of memory: Kill process 25253 (du) score 544 or sacrifice child
    [13893.342813] Killed process 25253 (du) total-vm:7111688kB, anon-rss:4838704kB, file-rss:152kB

    Has anyone else experienced this issue or one similar ?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Is this a share for email or websites and if its a email share. do you use dovecot or courier?

    You can disable the use of du (which is a fallback mode) under System > Server config > email > Mailbox quota statistics
  3. lee.veal

    lee.veal Member

    Thank you, The option has been disabled

    It is a pair of courier servers configured to for virtual mail box mounted on /var/vmail

    It is happening on both of them, which leads me to think it is a NSF issue

    192.168.100.XXX:/share/mail /var/vmail nfs rw,async,nfsvers=3,wsize=32768,rsize=32768 0 0
    192.168.100.XXX:/share/data /var/data nfs rw,async,nfsvers=3,wsize=32768,rsize=32768 0 0

    Side note , since the upgrade the server performance has increased considerably!

    once I chmod -x /usr/bin/du that is .. Thank you for your response .

Share This Page