drupal, phpmyadmin and localhost: drupal installation

Discussion in 'Server Operation' started by blesbok, Sep 22, 2008.

  1. blesbok

    blesbok New Member

    had phpmyadmin installed on my fedora8 box in /var/www/html. (lamp and ispconfig are set up too) when installing drupal, i was prompted about overwriting phpmyadmin files in this directory (files had identical names), i knew proceeding would mess things up. :rolleyes:

    consequently, i moved the contents of folder html to another in the same directory, html3. although impractical, either drupal or phpmyadmin can be run by editing DocumentRoot in apache: (in /etc/httpd/conf/httpd.conf)

    DocumentRoot "/var/www/html3" and changing this line.

    drupal is not yet fully installed as the step of creating the database is fraught with problems. what should the hostname be? (no remote hosting is intended) have had no success doing this from the command line and phpmyadmin is even less usable. on command line it goes like this:

    [root@billsrange ~]# mysqladmin -u admin -p create db_d
    Enter password:
    mysqladmin: connect to server at 'localhost' failed
    error: 'Access denied for user 'admin'@'localhost' (using password: YES)' :(

    something similar happens on the drupal installation after giving database details of a database which looked alright (i'd seen it in phpmyadmin with 43 tables) http://localhost/install.php?profile=default&locale=en, the database configuration screen gives this result:

    Failed to connect to your MySQL database server. MySQL reports the following message: Access denied for user 'admin'@'localhost' (using password: YES). :(

    please chuckle or laugh at this newby (i'll bear with some sneering too) :) and then tell me how to have htpd accept both drupal and phpmyadmin's existence and how i can continue with my drupal installation.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Please try root instead of admin as the MySQL username.
     
  3. blesbok

    blesbok New Member

    thanks, but sorry, i'll need more time

    thanks Falko

    regretably, i've been away from internet access for a couple of days and am just passing through now.

    please bear with me; i've tried the root username and the zero response from konsole means it's okay ;). on Mon 6 October i'll post to say how the installation proceeded. :eek:
     
  4. blesbok

    blesbok New Member

    unfortunately, this drupal installation remains elusive. :confused:

    after entering the database details on drupal's install wizard (for want of a better name), it crashed. am still able to run the install by posting http://localhost/install.php in a browser and that takes me to the first page where i select the install drupal in english option. on the next screen, with url
    http://localhost/install.php?profile=default&locale=en,
    firefox presents a blank screen with done underneath. konqueror will give this error (same as mentioned in the crash):

    An error occurred while loading http://localhost/install.php?profile=default&locale=en:
    Internal error in server
    localhost

    ("page loaded." was displayed below, only to disappear again)

    in the apache error log, i get the following:

    [error] [client ::1] PHP Fatal error: Call to undefined function _user_password_dynamic_validation() in /var/www/html/install.ph
    p on line 727, referer: http://localhost/install.php?profile=default

    is this environment of mine perhaps a little drupal unfriendly or have i stumbled on a bug? perhaps the real bug's the one with ten fingers rattling the keyboard... sorry to 'bug' you again, but any help will be much appreciated :cool:
     
  5. marpada

    marpada New Member

    Google the error (_user_password_dynamic_validatio), there some some threads about this problems in drupal site.
    ________
    Essential Vaaapp
    ________
    C25XE
     
    Last edited: May 13, 2011
  6. blesbok

    blesbok New Member

    jawohl, i do smell a(nother) bug!

    thanks m (sorry, can't see your name now)

    had thought of googling as you suggested. now to tell the others what i found...

    this thread http://drupal.org/node/203187#comment-701024 with 56 posts shed some light. post 52 said do this:

    mysql -u root -p
    i added: USE db_d
    then (as given): mysql> UPDATE system SET status=1 WHERE name='block' OR name='user' OR name='node' OR name='filter';

    :D RESULT: PROGRESS!! :)

    am now on the Configure site dialogue
     
  7. marpada

    marpada New Member

    That was a strange problem you had, I've installed Drupal quite a few times and everytime went smoothly :rolleyes:
    ________
    UPSKIRT GIRL
    ________
    Kid Paxil
     
    Last edited: May 13, 2011
  8. blesbok

    blesbok New Member

    grateful

    i'm thankful to have reached the end of this road, marpada :)

    the rest of the installation went fine (my first)

    perhaps i could mention something to clear a potential hurdle for others going the drupal route. to my surprise (and dismay) i was not able to log in as administrator. a look at drupal's faq gave a simple solution which worked: cookies had to be enabled in my browser for my site. ;)

    EOF
     

Share This Page