Drupal install fails due to Random Number Generator error

Discussion in 'Technical' started by seizethecarp, Jun 7, 2017.

  1. seizethecarp

    seizethecarp New Member

    I've been told this is technically a PHP problem and it's also an installation problem, so I'm posting to the catch-all forum.

    I need help whitelisting /dev/urandom to PHP's open_basedir setting for my particular setup without affecting the other sites on this server.
    I get this error while doing a Drupal install:
    Requirements problem
    Errors foundRandom number generationLess secureDrupal is unable to generate highly randomized numbers, which means certain
    security features like password reset URLs are notas secure as they should
    be.Instead, only a slow, less-secure fallback generator is available.The
    most likely cause is that open_basedir restrictions are in effect and/dev/urandom isnot on the whitelist. See the system requirements page for
    more information.Thereisno suitable CSPRNG installed on your system

    Editing the php.ini file will mess with others' sites on this box, right? I see people saying edit the vhosts file or the httpd file and there are tons of those, but not where they're "supposed" to be. I don't have a vhosts folder in /etc/www or have the directory etc/httpd either, for instance, but that's where people are generally directing others.

    DISTRIB_DESCRIPTION="Ubuntu 14.04.1 LTS"

    This below looks promising, except I have other sites to worry about (which is my fear about php.ini) and I am on Ubuntu:

    Edit the file /etc/php5/cli/php.ini and comment out the open_basedir setting
    in this file. Debian uses different php.ini filesand a open_basedir in the
    php.ini for shell scripts makes not much sense. The open_basedir should only
    be set for the websites and thats what ispconfig is doing automatically,
    even if its not defined in the global php.ini.​

    from https://www.howtoforge.com/communit...restriction-and-dev-urandom-not-within.71393/
  2. seizethecarp

    seizethecarp New Member

    So as an FYI in case someone else comes looking for an answer, modifying the php.ini file to whitelist /dev/urandom didn't help anything. None of the config files (php.ini included) were calling for open_basedir so that leads me to the site manager, ISPConfig. I don't have total admin on it and the version I'm using, 3.0.x.x leaves that in server configuration. I got my boss to add /dev/urandom to the list and still no luck. I also switched the site to a diff PHP handler and no luck there either. I posted this to the ISPConfig part of the forum and am hoping for a reply.

Share This Page