Drupal Clean URL's - NGINX

Discussion in 'Installation/Configuration' started by selcuk, Feb 21, 2014.

  1. selcuk

    selcuk New Member

    I have a drupal 7 cms in a subfolder installed the only thing is clean url's are not working i get a 404 Not Found Message. I have multiple drupal 7 sites on a site in subfolders. How can i make clean url's work ? I can't get it to work.

    ( Same on a magento website: clean url's not working )
    Running: Ubuntu 13.04 - NGinx - ISPC3
  2. srijan

    srijan New Member HowtoForge Supporter


    Have you created the 404.html page? If not then create the page. Its default location is

    Edit the file as follows:

    Now the main task which is needed is to edit this file /usr/local/nginx/conf/nginx.conf

    make changes like this

    Now save the file & reload the NGINX

  3. selcuk

    selcuk New Member

    Thank you for your effort but i get the good 404 page that's not the point.
    The point is: Clean url's are not working.
    So for instance www.domain.tld/cms/user is not working.
    I think i have to give directive's in the Options - Nginx Tab... but wich one?
  4. srijan

    srijan New Member HowtoForge Supporter

  5. selcuk

    selcuk New Member

    Srijan the commit not there anymore... 400 - Invalid hash parameter

    I'm glad that you're helping me m8
  6. till

    till Super Moderator Staff Member ISPConfig Developer

  7. selcuk

    selcuk New Member

    Now i get a 502 Bad Gateway

    2014/02/21 12:38:56 [error] 3019#0: *7 connect() failed (111: Connection refused) while connecting to upstream, client: request: "GET /d7/ HTTP/1.1", upstream: "fastcgi://"
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Take a look at the php-fpm log file.
  9. selcuk

    selcuk New Member

    It was the port 9000 in the nginx directive that was set not correctly.
    I've changed that to 9008 belonging to the user... the website is now working with the directive's...

    but clean url's are still not working.

    The cms is in a subfolder with the settings in ISPC3:
    CGI = on
    SSI = on
    Redirects = none
    Socket for PHP-FPM = off
    Process Manager=dynamic
    Niginx directives just as till posted but with port 9008 - https://timmehosting.de/drupal-hosting-auf-nginx

Share This Page