Drupal and TinyMCE and images...

Discussion in 'Installation/Configuration' started by yurtboy, Mar 27, 2007.

  1. yurtboy

    yurtboy New Member

    On a non ispconfig server it worked like a snap...
    But when I insert an image it just does not show up.
    Both are clean installs.
    All the same settings.....
    Tried fck too
    This server does Joomla and Egroupware great so I think it is just an .htaccess or other setting.
    I followed the how to online for drupal and ispconfig.
    Thanks
    Al
     
  2. yurtboy

    yurtboy New Member

    Figured it out....

    So I think drupal puts an .htaccess in the folder you choose for you files folder in
    Administer --> Filesettings
    I moved it to HTACCESS and then created a link to the one I was told to use in the turorial.
    Maybe there is a better way?
    Now I can insert pictures with Tinymce.
    I'de be more excited if it was not 1:30 am and if I did not start at 10pm.
    Al
     
  3. yurtboy1

    yurtboy1 New Member

    NOPE still not sure here

    Non-ispconfig sites it sets up easily.
    With ISPConfig sites still have a but of trouble.
    Full HTML is on with Drupal.
    Preview and Edit show a broken image.
    View / Save and it works fine.
    Here is my .htaccess
    Here is the ISPConfig Settings
    Alright so I am going to try some other settings that worked for other ISPConfig sites but any help would be appreciated.
    Thansk
     
  4. falko

    falko Super Moderator

    Take a look at the end of your main Apache configuration file. At the end there should be a section added by the ISPConfig installer. Set AllowOverride to All and restart Apache.
     
  5. yurtboy1

    yurtboy1 New Member

    So line 424 of the main apache file

    So the AllowOverride All was AllowOverride None
    Bu still edit mode only shows a broken image but Preview and regular view mode show fine.
    ps..I am willing to pay to fix this since it gets me with every new site.
    Al
     
  6. falko

    falko Super Moderator

    Comment out the AllowOverride Indexes AuthConfig Limit FileInfo line and restart Apache.
     
  7. yurtboy1

    yurtboy1 New Member

    Same error, attached is that apache.conf

    Done it all and same error (not at the console though)
    I change many lines, maybe too many ( -:
    Again this works on other sites on the same server.
    Could it be a cache thing?
     

    Attached Files:

  8. falko

    falko Super Moderator

    Have you tried to clear your browser's cache?
     
  9. yurtboy1

    yurtboy1 New Member

  10. yurtboy1

    yurtboy1 New Member

    Yes.
    Using firefox and disable cache.
    Same problem.
    uhhg
     
  11. breauxlg

    breauxlg New Member

    This was the problem with my 505 error

    Falko,
    Thanks so much. I found this by accident. The post you just moved into ispconfig for me was solved by this solution (the apache config override stuff).
    Thanks, Thanks, Thanks.
    I'll flag the other as solved with a link to this thread.
     
  12. smartin

    smartin New Member

    Falco,

    Ignore this please, I'm actually using ISPc3, not V2.

    I'll keep looking for a solution.

    S

    Forgive newbness...

    I seem to be having more or less the same problem as the OP (fckeditor/IMCE).

    Where is the file you are referring to here, please?

    Thanks :)


    S
     
    Last edited: Jan 26, 2010

Share This Page