dpkg: exim4-config: dependency problems, but removing anyway as you requested

Discussion in 'HOWTO-Related Questions' started by ChrisZ, Jan 4, 2013.

  1. ChrisZ

    ChrisZ New Member

    I installed postfix and dovecot according to Multiserver Setup With Dedicated Web, Email, DNS & MySQL Database Servers On Debian Squeeze With ISPConfig 3...

    Code:
    apt-get -y install postfix postfix-mysql postfix-doc openssl getmail4 rkhunter binutils dovecot-imapd dovecot-pop3d

    (mysql-client mysql-server not included in the above command since I already installed it)


    ...and aptitude complained about exim4 dependencies. I'm assuming this is OK but just want to be sure.

    Code:
    The following extra packages will be installed:
      dovecot-common libperl5.10 libpq5 ssl-cert unhide
    Suggested packages:
      binutils-doc postfix-pgsql postfix-ldap postfix-pcre sasl2-bin resolvconf
      postfix-cdb ufw tripwire openssl-blacklist
    The following packages will be REMOVED:
      exim4 exim4-base exim4-config exim4-daemon-light
    The following NEW packages will be installed:
      binutils dovecot-common dovecot-imapd dovecot-pop3d getmail4 libperl5.10
      libpq5 postfix postfix-doc postfix-mysql rkhunter ssl-cert sudo unhide
    0 upgraded, 14 newly installed, 4 to remove and 0 not upgraded.
    Need to get 16.2 MB of archives.
    After this operation, 44.2 MB of additional disk space will be used.
    [...]
    Preconfiguring packages ...
    Fetched 16.2 MB in 2s (5,670 kB/s)
    [...]
    Removing exim4 ...
    Selecting previously deselected package ssl-cert.
    [...]
    Unpacking ssl-cert (from .../ssl-cert_1.0.28_all.deb) ...
    Processing triggers for man-db ...
    dpkg: exim4-config: dependency problems, but removing anyway as you requested:
     exim4-base depends on exim4-config (>= 4.30) | exim4-config-2; however:
      Package exim4-config is to be removed.
      Package exim4-config-2 is not installed.
      Package exim4-config which provides exim4-config-2 is to be removed.
     exim4-base depends on exim4-config (>= 4.30) | exim4-config-2; however:
      Package exim4-config is to be removed.
      Package exim4-config-2 is not installed.
      Package exim4-config which provides exim4-config-2 is to be removed.\[...]
    Removing exim4-config ...
    dpkg: exim4-daemon-light: dependency problems, but removing anyway as you requested:
     bsd-mailx depends on default-mta | mail-transport-agent; however:
      Package default-mta is not installed.
      Package exim4-daemon-light which provides default-mta is to be removed.
      Package mail-transport-agent is not installed.
      Package exim4-daemon-light which provides mail-transport-agent is to be removed.
     bsd-mailx depends on default-mta | mail-transport-agent; however:
      Package default-mta is not installed.
      Package exim4-daemon-light which provides default-mta is to be removed.
      Package mail-transport-agent is not installed.
      Package exim4-daemon-light which provides mail-transport-agent is to be removed.
    Removing exim4-daemon-light ...
    Stopping MTA: exim4_listener.
    
    Thank you,
    Chris
     
  2. falko

    falko Super Moderator

    I guess this is ok. Do you use the default /etc/apt/sources.list, or did you modify it?
     
  3. ChrisZ

    ChrisZ New Member

    Good to know. :)

    I left the default sources.list in place.

    Code:
    # deb http://ftp.us.debian.org/debian/ squeeze main
    
    deb http://ftp.us.debian.org/debian/ squeeze main
    deb-src http://ftp.us.debian.org/debian/ squeeze main
    
    deb http://security.debian.org/ squeeze/updates main
    deb-src http://security.debian.org/ squeeze/updates main
    
    # squeeze-updates, previously known as 'volatile'
    deb http://ftp.us.debian.org/debian/ squeeze-updates main
    deb-src http://ftp.us.debian.org/debian/ squeeze-updates main
     
  4. falko

    falko Super Moderator

    It should be ok then.
     

Share This Page