Downloads from ISPConfig Server

Discussion in 'ISPConfig 3 Priority Support' started by Quaxth, Sep 24, 2013.

  1. Quaxth

    Quaxth New Member

    Downloads from ISPConfig Server are:
    1. very slow up to 20KB/sec
    2. NO Resume in case the download is broken!
    [​IMG]

    I've an Cable connection with 20Mbps+ (upto 50Mbps) and could normally download with 3MB/sec +! NO Resume by downloading huge files is quite "unfriendly". To download an file from 901MB within app. ~9+ hours, is just outraged!

    I started the download of the file already the 3rd time because the download were broken 2 times already and could NOT Resume! On this I'm since yesterday afternoon!

    Thanks.
     
  2. Quaxth

    Quaxth New Member

    ISPConfig3 Manual

    In the Manual is an problem with Page 124:
    [​IMG]

    Or it is an problem from downloading which I doubt!

    Thanks
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Hi,

    I'am sorry to hear that you had problems with the download speed.

    There must be a issue with the connection of your internet access provider to servers in europe. I tested the download speed over different networks, the download of the manual took always about 15 - 20 seconds for the 21MB file, so there is no speed issue from our server or internet connection side. We are connected with 1Gbit in the datacenter with a guaranteed bandwidth of 200Mbit and the datacenter has a direct connection to DECIX, one of the largest internet nodes in the world.

    If you have problems with the download speed trough your access provider, then please contact us by email and we will download the manual for you and send you your copy of the manual by email.

    The formatting issue on page 124 is known and we will fix it for the next release of the manual.
     
  4. Quaxth

    Quaxth New Member

    As I wrote, my connection is 20-50Mbps and that 20Mbps is the minimum I get all times.

    Maybe the TraceRoute will tell you something:
    [​IMG]

    and:
    [​IMG]
    And what's about the resume? Couldn't you enable Resume for downloads?

    Thanks a lot.
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    We had it enabled before and it caused a lot of inconsistent downloads, so we had to disable it again.
     
  6. Quaxth

    Quaxth New Member

    Fact is, that I'm, after more than 24h of downloading: The_Perfect_Server_-_Debian_Wheezy_x86_64__Apache2__BIND__Dovecot__ISPConfig_3___VirtualBox_Image__2.zip with an size of 901.79 MB, and after two broken downloads, now by 71.24% of the 3rd! I normally could download within 1h more than 5GB! and don't need to be worry about broken downloads because Resume is working!

    Thanks.
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    I just tested the download of that file, overall download time for 902 MB: 4 minutes. And I'am on a completely different ISP here in europe then the one that runs the servers. I'am really sorry that you ISP in thailand has such a bad connection to DECIX and europe.
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    If your download stops again, then I will try to give you a seperate download e.g. by ftp.
     
  9. Quaxth

    Quaxth New Member

    That's at the moment:
    [​IMG]

    I downloaded from the UK 320MB Android Firmware today within 3½min! On the same connection!

    Maybe, if you get more complaints about that, why not create a Mirror by let say: Mega.co.nz because they giving 50GB for free and the download is ok with resume! I really don't mind about low speed IF Resume is enabled! Than I don't have to sit down and look at the monitor all times because of crashes!

    You see, as I had installed the Debian and ISPConfig yesterday several times, once I wasn't able to get the apps from your Server even not with IP! it started an than was hanging for more than 40min and finally stopped totally, As try to re-download was getting an error. So needed an other re-installation! I'm not sure that those problem lies in Thailand connection, it could also be in the intl. connection, some Gateway, or even within Germany!
    You seen the trace routes! I'll do an other trace scan later with a different software and see the result from that! According to my ISP here in Thailand, they didn't blocking or having any other problem. I called them today also for to test! It's a pain in the ass!

    Ok, will let you know the next later on.

    Cheers.
     
  10. Quaxth

    Quaxth New Member

    Download from ispconfig.org

    I installed the whole again because I also was registering a new domain and to solve problems with Name Servers.

    The download of: http://www.ispconfig.org/downloads/ISPConfig-3-stable.tar.gz still didn't works for me from the Debian Server, instead it works from an Windows desktop. Finally I had to use the IP 144.76.136.125 instead of ispconfig.org and that worked for installation.

    I not used to type the command, I was using Copy and Paste to avoid any error and/or Typo!

    Now time to start testing the server!!

    Thanks and Cheers.
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    thats strange. I just tested the downlad with:

    wget http://www.ispconfig.org/downloads/ISPConfig-3-stable.tar.gz

    from 2 different networks on debian and it worked fine. Maybe the name resolving of your debian server was not 100% ok. Try to edit the /etc/resolv.conf file and change the nameserver lines to:

    nameserver 8.8.8.8
    nameserver 8.8.4.4

    this are the public namservers from google, they work very reliable.
     
  12. Quaxth

    Quaxth New Member

    The Google Name Servers are set already correctly by installation.
    And I get an other problem: I could not connect from Internet to the CP. Both Port 80 and 8080 are correctly forwarded to the server.
    But: while try mi public IP with port 8080 I come to the log on page of my Modem Router. That could be mean, that the Router is using port 8080 for remote connection and could not be used for other services. Could that be??

    What's about if I set the port for CP let say to 18080? And what els of ports need to be forwarded to the ISPConfig Server:"

    Please look at the pic of the forwarded ports:
    [​IMG]

    This drives me crazy!!

    Thanks a lot!
     
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, this can be the case. Change the ispconfig port in the file /etc/apache2/sites-available/ispconfig.vhos to another port, e.g. 8082 and restart apache. dont use 8081 as this is in use already.
     
  14. Quaxth

    Quaxth New Member

    It is the case> I had disabled the port 8080 in Router and could connect using an 3G external connection for testing. Will do the change to 8082.

    Thanks a lot.
     
  15. Quaxth

    Quaxth New Member

    I changed the port 8080 to 8082 (3 times) see picture:

    [​IMG]

    Now I could not open the CPanel again!

    What that means?
     
  16. Quaxth

    Quaxth New Member

    I changed the port back to 8080 and it worked. Change again to 8082 = didn't work, changed back = works!

    Is there more entries in other files to be changed?

    Thanks.
     
  17. till

    till Super Moderator Staff Member ISPConfig Developer

    No, its just this file. maybe you have the firewall activated? In this case you have to open the port in the firewall as well.

    You might also want to try a different port like 8090.
     
  18. Quaxth

    Quaxth New Member

    I'm not sure with the firewall, I just start to get to play with the CP. Have my normal work to do as well!!

    Will try other ports after checking about the Firewall. Normally I didn't need an Firewall because I run Smoothwall for the whole LAN and I automatically open new ports in Smoothwall if I put them in system.

    Let you know an about 1h what happen! Now it's Diner time: 19:00h!!

    Thanks Till.
     
  19. Quaxth

    Quaxth New Member

    OK Till, got it to work now with port 8090!

    Question: the IP in Server IP addresses of ISPConfig has to be set to the public IP or to the LAN IP? I'd set to public IP. The servers name is host.xxx-xxxx.biz while the Domain is registered as xxx-xxxx.biz so I placed at the same screen host.xxx-xxxx.biz and the added ports are 80 and 443. Need also now 8090 there?

    Thanks.
     

Share This Page