dovecot problem - help please!

Discussion in 'Server Operation' started by samoand, Jan 2, 2008.

  1. samoand

    samoand New Member

    Greetings! I'm trying to configure dovecot on CentOS5.1, and here's where I'm hitting a wall. There are 2 machines: Windows and CentOS
    1. I can telnet from CentOS machine to itself using either domain name or ip on port 110 and read all email, no problem. However, I can't do the same from the Windows machine.
    2. Probably related to "1", but with a twist. I can't connect from Outlook client; "Test Account Settings" comes back with "Outlook cannot connect to your incoming (POP3) email server". However, test e-mail message from Outlook makes it to the test account and is viewable locally on the CentOS machine. In fact, it's viewable if I telnet to CentOS machine from itself on 110.

    Closest setting in dovecot.conf that I found might be a suspect was "listen", it's currently set to default
    listen = [::]
    I tried to play with it and change it to all variables that would come to mind (ip, domain name, mail server name and combinations thereof) - without any result.
    Any thoughts regarding the situation? Thanks.
  2. falko

    falko Super Moderator ISPConfig Developer

    What are the outputs of
    netstat -tap
    iptables -L
    ? Did you disable SELinux?
  3. samoand

    samoand New Member

    Got it.
    It was "listen" directive in dovecot.conf, nonetheless.
    Replaced default "[::]" with "*" and everything worked. Apparently [::], while tuned to handle IPv6 interfaces, is less reliable for IPv4. My second mistake was trying to play with combinations of domain names and ip-s on that line: it doesn't like multiple entries.
    Last edited: Jan 6, 2008

Share This Page