Dovecot Master To Master Issues

Discussion in 'Server Operation' started by DVader, Feb 9, 2018.

  1. DVader

    DVader New Member

    Hello there !

    I am trying to setup a real time master to master dovecot replication between 2 servers following the guide from wiki

    It runs fine if i trigger the sync manually but when a new email arrives or some use changes the email account through imap creating a new folder nothing happens unless i trigger it manually...

    Has anyone made it work realtime ..? IS there any guide i cannot follow to make it work ..?

    OS:
    CentOS Linux release 7.4.1708 (Core)
    Dovecot version is 2.2.33.2 through IUS

    The setup i am using on both servers is

    # This sets globally the port needed to connect
    # to the doveadm service
    #doveadm_port = 2727

    # Set the password globally to use for connecting to
    # and requiring for the doveadm service
    doveadm_password = mypassword

    # Set the directory for validating certificates
    # provided when running with SSL enabled
    # Should be the standard OpenSSL certificate directory by default
    #ssl_client_ca_dir = /etc/ssl/certs

    #You can configure how many dsyncs can be run in parallel (10 by default)
    replication_max_conns = 10

    service config {
    unix_listener config {
    user = dovecot
    }
    }

    # Configure the doveadm service to listen
    service doveadm {
    user = dovecot
    inet_listener {
    # port to listen on
    port = 1234
    # enable SSL
    ssl = no
    }
    }

    # Configure the aggregator service for notifications
    service aggregator {
    fifo_listener replication-notify-fifo {
    # Your mail user that's managing files generally is used here
    #user = mail
    mode = 0600
    }
    unix_listener replication-notify {
    user = dovecot
    mode = 0600
    }
    }

    # Configure the replicator service
    service replicator {
    process_min_avail = 1
    unix_listener replicator-doveadm {
    mode = 0600
    }
    }

    # Configure target hosts for replication
    # tcps can be tcp if you don't want to connect with SSL
    # :port can be omitted if it's the default set globally for doveadm
    plugin {
    mail_replica = tcp:server1.domain.com:2727
    }


    Αny help would be apricated... cause i am little lost on what's is the error
     
    Last edited: Feb 9, 2018
  2. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    the mail_plugins configuration and the services for po3, imap....?
    mail_fsync = never
    mail_plugins = notify replication quota
    protocol imap {mail_plugins = $mail_plugins imap_quota}
    protocol pop3 {pop3_uidl_format = %08Xu%08Xv}
    protocol lda {mail_plugins = $mail_plugins sieve
    postmaster_address=[email protected]
    }
     

Share This Page