dovecot Mail delivery System returns “unknown user” and client authentication fails

Discussion in 'Installation/Configuration' started by adrigen, Feb 11, 2013.

  1. adrigen

    adrigen New Member

    I have dovecot installed on Ubuntu 12.04. I am using Ispconfig3 to manage the virtual users. I have been through the http://wiki2.dovecot.org/TestInstallation process and everything (except the ssl) works: I can log in using telnet. I can open the inbox.

    However when I try to send an email to one of the accounts from gmail, the email gets returned from "Mail Delivery System" saying "unknown user: 'test'". Trying to receive mail using a client gives an authentication error.

    There don't seem to be any relevant errors in /var/log/ mail.err or mail.log, exept: CB7D01242D5: to=<test@adrian.com.au>, relay=local, delay=0.49, delays=0.01/0.38/0/0.1, dsn=5.1.1, status=bounced (unknown user: "test")

    One thing I am suspicious of is that I have not used a sub domain for my mail server and I am not sure if this causes problems. (Now or in the future).

    What should I do to troubleshoot this further?

    dovecot.conf: pastie.org/6113418 master.cf: pastie.org/6113424 main.cf: pastie.org/6113428
     
    Last edited: Feb 11, 2013
  2. Parsec

    Parsec New Member

    I'm assuming you setup the mail domain and users in ispconfig?

    Assuming you are using postfix... take a look in /etc/postfix/main.cf and look for the line "mydestination="

    If you have adrian.com.au in that line, then you are screwed :) Postfix will think that's a local mailbox and not lookup the virtual tables in mysql for the domain and it's users.

    How to fix? Well remove your domain from that mydestination = line, this will leave just localhost stuff left there. Then restart postfix.

    Then, postfix should look up the virtual maps when an email arrives and find the mail setup you did in ispconfig.

    If this doesn't work.. I need more info :)
     
    budgierless likes this.
  3. budgierless

    budgierless Member HowtoForge Supporter

    i had my domian their, and have moved it, but i stall have the fqdn their is that ok?
     

Share This Page