dovecot - increase login_max_processes_count

Discussion in 'Installation/Configuration' started by carpman, Jun 28, 2013.

  1. carpman

    carpman Member

    Hi, failed to send an email with smtp block error.

    check of the logs showed the account had these errors
    Code:
    server dovecot: dovecot: All login processes are in use. You may need to increase login_max_processes_count
    Code:
    server dovecot: IMAP(mail@domain.co.uk): Inotify instance limit for user exceeded, disabling. Increase /proc/sys/fs/inotify/max_user_instances
    I have done a google and seems i need to edit one or all of following settings

    Code:
    login_process_per_connection = yes
    login_processes_count = 3
    login_max_processes_count = 128
    login_max_connections = 256
    this what dovecot.conf do i use and what is exact sysntax?

    I found:

    Code:
    /etc/dovecot/dovecot.conf
    and
    /var/run/dovecot/dovecot.conf 
    Also tried

    Code:
    echo 256 > /proc/sys/fs/inotify/max_user_instances
    thanks
     
  2. carpman

    carpman Member

    ok think i have this worked out, but it also think it not the problem.

    will make another post for that.
     
  3. githerdone

    githerdone New Member

    I'm having the same issue

    We get these errors on the email server every day. I increased the login max process once and it broke the email so I took it back.

    Jun 25 15:23:39 dovecot: Warning: All login processes are in use. You may need to increase login_max_processes_count
    Jun 25 15:28:40 dovecot: Warning: All login processes are in use. You may need to increase login_max_processes_count
    Jun 25 15:33:41 dovecot: Warning: All login processes are in use. You may need to increase login_max_processes_count
    Jun 25 15:36:33 imap-login: Panic: file priorityq.c: line 122 (priorityq_remove_idx): assertion failed: (idx < count)
    Jun 25 15:36:33 dovecot: Error: child 27280 (login) killed with signal 6 (core dumps disabled) (ip=127.0.0.1)
    Jun 25 15:38:42 dovecot: Warning: All login processes are in use. You may need to increase login_max_processes_count
    Jun 25 15:43:43 dovecot: Warning: All login processes are in use. You may need to increase login_max_processes_count

    How do I increase my login max processes with breaking my email server? am I being invaded by spammers or other people that would increase the logins? I have a large user base so this server needs to be able to handle the logins to the email server.

    Thanks in advance
    Kyle
     

Share This Page