dovecot fails to start

Discussion in 'Server Operation' started by satimis, May 23, 2008.

  1. satimis

    satimis New Member

    Hi folks,


    Ubuntu 6.05.3 drake amd64
    Postfix 2.2.10
    dovecot-common 1.0.beta3
    dovecot-imapd 1.0.beta3
    dovecot-pop3d 1.0.beta3


    I'm following;

    Ubuntu Server Guide
    https://help.ubuntu.com/6.06/ubuntu/serverguide/C/index.html

    to build this LAMP server w/o having encountered much problem. After completion I started testing it and found postfix can't receive mails.


    Remark:
    having run update and upgrade several times


    $ telnet localhost pop3
    Code:
    Trying 127.0.0.1...
    telnet: Unable to connect to remote host: Connection refused

    $ sudo /etc/init.d/dovecot restart
    Code:
    Restarting mail server: dovecotError: Can't use SSL certificate /etc/ssl/certs/dovecot.pem: No such file or directory
    

    $ sudo locate dovecot.pem
    No printout


    $ ls -al /etc/ssl/certs/
    Code:
    total 24
    drwxr-xr-x 2 root root 4096 2008-05-19 22:27 .
    drwxr-xr-x 4 root root 4096 2008-04-18 07:28 ..
    lrwxrwxrwx 1 root root   21 2008-04-18 07:28 a69cfdd6 -> ssl-cert-snakeoil.pem
    -rw-r--r-- 1 root root 1208 2008-05-19 22:25 cacert.pem
    -rw-r--r-- 1 root root  904 2008-05-07 20:39 server.crt
    -rw-r--r-- 1 root root  895 2008-05-19 22:20 smtpd.crt
    -rw-r--r-- 1 root root 1139 2008-04-18 07:28 ssl-cert-snakeoil.pem
    


    /etc/dovecot/dovecot.conf
    Code:
    ssl_cert_file = /etc/ssl/certs/dovecot.pem
    ssl_key_file = /etc/ssl/private/dovecot.pem
    ssl_disable = no
    disable_plaintext_auth = no
    
    Remark:
    Previously dovecot.pem were there.


    $ telnet localhost pop3
    Code:
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    +OK Dovecot ready.
    quit
    +OK Logging out
    Connection closed by foreign host.
    
    It worked prviously.


    Please help. TIA


    B.R.
    satimis
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. satimis

    satimis New Member

    Hi till,


    Thanks for your advice and URL. Steps performed as follows;


    $ ls /etc/ssl/certs/
    Code:
    a69cfdd6  cacert.pem  server.crt  smtpd.crt  ssl-cert-snakeoil.pem
    

    $ sudo ls /etc/ssl/private/
    Code:
    cakey.pem   server.key.origin.20080507  ssl-cert-snakeoil.key
    server.key  smtpd.key
    

    $ sudo ln -s /etc/ssl/certs/ssl-cert-snakeoil.pem /etc/ssl/c
    erts/dovecot.pem
    Code:
    Password:
    

    $ sudo ln -s /etc/ssl/private/ssl-cert-snakeoil.key /etc/ssl
    /private/dovecot.pem
    No complaint


    $ ls -l /etc/ssl/certs/
    Code:
    total 16
    lrwxrwxrwx 1 root root   21 2008-04-18 07:28 a69cfdd6 -> ssl-cert-snakeoil.pem
    -rw-r--r-- 1 root root 1208 2008-05-19 22:25 cacert.pem
    lrwxrwxrwx 1 root root   36 2008-05-23 16:46 dovecot.pem -> /etc/ssl/certs/ssl-cert-snakeoil.pem
    -rw-r--r-- 1 root root  904 2008-05-07 20:39 server.crt
    -rw-r--r-- 1 root root  895 2008-05-19 22:20 smtpd.crt
    -rw-r--r-- 1 root root 1139 2008-04-18 07:28 ssl-cert-snakeoil.pem
    

    $ sudo ls -l /etc/ssl/private/
    Code:
    total 20
    -rw-r--r-- 1 root root     963 2008-05-19 22:25 cakey.pem
    lrwxrwxrwx 1 root root      38 2008-05-23 16:49 dovecot.pem -> /etc/ssl/private/ssl-cert-snakeoil.key
    -rw-r--r-- 1 root root     963 2008-05-07 20:39 server.key
    -rw-r--r-- 1 root root     963 2008-05-04 01:01 server.key.origin.20080507
    -rw-r--r-- 1 root root     887 2008-05-19 22:21 smtpd.key
    -rw-r----- 1 root ssl-cert 887 2008-04-18 07:28 ssl-cert-snakeoil.key
    

    $ sudo /etc/init.d/dovecot restart
    Code:
    Restarting mail server: dovecotWarning: Fixing permissions of /var/run/dovecot to be world-readable
    Warning: Corrected permissions for login directory /var/run/dovecot/login
    .
    

    $ telnet localhost pop3
    Code:
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    +OK Dovecot ready.
    quit
    +OK Logging out
    Connection closed by foreign host.
    

    But still it can't receive emails.


    I found on router ports, 25, 110, 143, 443, 995 etc. forward to 192.168.0.10 NOT the IP address of this server, 192.168.0.52.


    Tried forwarding port 143 to this server 192.168.0.52

    Still can't receive emails. Please advise where shall I check?


    TIA.


    Furthermore on building this server previously.

    /etc/ssl/certs/dovecot.pem
    /etc/ssl/private/dovecot.pem

    were there. I can't resolve why they disappear. I don't run this server daily. I resume testing only when I have time.


    B.R.
    satimis
     
  4. satimis

    satimis New Member

    Hi folks,


    Problem solved and emails received as follows;


    1) on /etc/postfix/main.cf
    add;
    Code:
    mydestination = localhost.satimis.com
    
    2) on router
    forward port 25 to 192.168.0.52


    restart postfix


    Now emails can be received and delivered to /home/user/Maildir/new/


    As curiosity, is there something on mail server similar to virtual host on webserver. With only one public IP mails can be delivered to either mail server-1 or mail server-2


    B.R.
    satimis
     

Share This Page