Dovecot fails to deliver to all mail clients

Discussion in 'Server Operation' started by zwelabantu, Jun 22, 2009.

  1. zwelabantu

    zwelabantu New Member

    Hello everyone

    I am new to linux and recently created a mail server on a SusE linux 10.2 Machine using POstfix and Dovecot.

    Postfix seems to be working fine as mail gets delivered to all user's mail boxes and on checking mail on thbe mboxes it is there. However I am unable to read mail using a client such Kmail, Mutt, Outlook, Outlook Express.

    When I use Telnet on port 110 I am able to loging using user's login credentials, but on running the command 'stat' it shows that there is no mail. but mail is there cause I have checked manually and /var/log/dovecot.log shows the following.

    dovecot: Jun 19 14:29:08 Info: pop3-login: Aborted login: user=<root>, method=PLAIN, rip=10.29.128.164, lip=10.29.128.164, secured
    dovecot: Jun 19 14:29:08 Info: auth(default): passwd-file(zwelabantu,10.29.128.164): unknown user
    dovecot: Jun 19 14:29:10 Info: pop3-login: Aborted login: user=<zwelabantu>, method=PLAIN, rip=10.29.128.164, lip=10.29.128.164, secured
    dovecot: Jun 19 14:39:10 Info: auth(default): passwd-file(root,10.29.128.164): unknown user
    dovecot: Jun 19 14:39:12 Info: pop3-login: Aborted login: user=<root>, method=PLAIN, rip=10.29.128.164, lip=10.29.128.164, secured
    dovecot: Jun 19 14:39:12 Info: auth(default): passwd-file(zwelabantu,10.29.128.164): unknown user
    dovecot: Jun 19 14:39:14 Info: pop3-login: Aborted login: user=<zwelabantu>, method=PLAIN, rip=10.29.128.164, lip=10.29.128.164, secured
    dovecot: Jun 19 14:49:14 Info: auth(default): passwd-file(root,10.29.128.164): unknown user
    dovecot: Jun 19 14:49:16 Info: pop3-login: Aborted login: user=<root>, method=PLAIN, rip=10.29.128.164, lip=10.29.128.164, secured
    dovecot: Jun 19 14:49:16 Info: auth(default): passwd-file(zwelabantu,10.29.128.164): unknown user
    dovecot: Jun 19 14:49:18 Info: pop3-login: Aborted login: user=<zwelabantu>, method=PLAIN, rip=10.29.128.164, lip=10.29.128.164, secured
    dovecot: Jun 19 14:59:18 Info: auth(default): passwd-file(root,10.29.128.164): unknown user
    dovecot: Jun 19 14:59:18 Info: pop3-login: Aborted login: user=<root>, method=PLAIN, rip=10.29.128.164, lip=10.29.128.164, secured
    dovecot: Jun 19 14:59:18 Info: auth(default): passwd-file(zwelabantu,10.29.128.164): unknown user
    dovecot: Jun 19 14:59:20 Info: pop3-login: Aborted login: user=<zwelabantu>, method=PLAIN, rip=10.29.128.164, lip=10.29.128.164, secured
    dovecot: Jun 19 15:09:20 Info: auth(default): passwd-file(root,10.29.128.164): unknown user
    dovecot: Jun 19 15:09:22 Info: pop3-login: Aborted login: user=<root>, method=PLAIN, rip=10.29.128.164, lip=10.29.128.164, secured
    dovecot: Jun 19 15:09:22 Info: auth(default): passwd-file(zwelabantu,10.29.128.164): unknown user
    dovecot: Jun 19 15:09:24 Info: pop3-login: Aborted login: user=<zwelabantu>, method=PLAIN, rip=10.29.128.164, lip=10.29.128.164, secured
    dcmailserver:/var/log # tail -20 dovecot.log

    I have now been struggling with this for 2 months, anyone who can help me with this will be much appreciated.
     
  2. topdog

    topdog New Member HowtoForge Supporter

    Thats because your dovecot is not properly configured (it is configured to use a passwd file for authentication)
     
  3. zwelabantu

    zwelabantu New Member

    If I don't use a passwd file for authentication what do I need to use and how should I configure that.
     
  4. topdog

    topdog New Member HowtoForge Supporter

    Code:
    auth default {
      mechanisms = plain login
      passdb pam {
      }
      userdb passwd {
      }
    }
    Which uses pam
     
  5. zwelabantu

    zwelabantu New Member

    After implementing changes to my dovecot.conf this is the error message I get. Tried a few solution to no avail. what should I configure further.

    Info: auth(default): pam(zzzzzzzzzzz@xxxxxxxxx.co.za,127.0.0.1): pam_authenticate() failed: User not known to the underlying authentication module
     
  6. topdog

    topdog New Member HowtoForge Supporter

    How did you create your users ? are they system users ?
     
  7. zwelabantu

    zwelabantu New Member

    Dovecot fails to deliver to mail clients

    I am using system users created manually and still have my passwd with all their login details. Here is a sample of the passwd file.

    zwelabantu@dariunhouse.co.za:{PLAIN}blablabla.

    I have just added the following

    zwelabantu:{PALIN}blablabla

    and tested the POP3 login using telnet and it log in without error, but now when i run the stat or list command I get

    +0K 0 messages.
     
  8. topdog

    topdog New Member HowtoForge Supporter

    In that case you are not using system users, your users are in a passwd file.

    Okay can you post the following files, main.cf and dovecot.conf.
     
  9. zwelabantu

    zwelabantu New Member

    Well my mail work fine now and all mail is now being delivered to mail clients such as outlook and outlook express.

    Thanks for your help. the changes i made suddenly had an impact. Users are able to send and receive mails using their local mail clients.
     

Share This Page