Dovecot error plugin... no recive mail..

Discussion in 'Server Operation' started by ZIZU, Apr 14, 2011.

  1. ZIZU

    ZIZU New Member

    Hi to all !

    i have this problem...
    i had install centos 5.6 (i386) on myserver, i use dovecot (1.1.20
    ) postfix and squirrel mail for mail.

    I can send mail to my account (like gmail.com)... but if i reply, i don't recive email...

    this is the tail of maillog
    Apr 14 14:06:30 server postfix/qmgr[4117]: 4A495D07DA: removed
    Apr 14 14:06:30 server postfix/pipe[4518]: BCE65D07DC: to=<XXXX>, relay=dovecot, delay=0.06, delays=0.02/0.02/0/0.03, dsn=4.3.0, status=deferred (temporary failure)
    Apr 14 14:07:00 server postfix/smtpd[4449]: disconnect from mail-ww0-f41.google.com[74.125.82.41]
    Apr 14 14:07:05 server postfix/smtpd[4449]: connect from smtplq-out8.aruba.it[62.149.158.28]
    Apr 14 14:07:05 server postfix/smtpd[4449]: D3ABDD07DA: client=smtplq-out8.aruba.it[62.149.158.28]
    Apr 14 14:07:05 server postfix/cleanup[4511]: D3ABDD07DA: message-id=<4DA6E1DB.4090308my_host_email>
    Apr 14 14:07:05 server postfix/qmgr[4117]: D3ABDD07DA: from=<my_good_email_on_gmail>, size=19302, nrcpt=1 (queue active)
    Apr 14 14:07:05 server postfix/smtpd[4449]: disconnect from smtplq-out8.aruba.it[62.149.158.28]
    Apr 14 12:07:06 server postfix/smtpd[4323]: 4F6CBD07DD: client=unknown[127.0.0.1]
    Apr 14 14:07:06 server postfix/cleanup[4511]: 4F6CBD07DD: message-id=<4DA6E1DB.4090308my_host_email>
    Apr 14 12:07:06 server postfix/smtpd[4323]: disconnect from unknown[127.0.0.1]
    Apr 14 14:07:06 server postfix/qmgr[4117]: 4F6CBD07DD: from=<my_good_email_on_gmail>, size=19746, nrcpt=1 (queue active)
    Apr 14 14:07:06 server deliver(XXXX): dlopen(/usr/lib/dovecot/lda/lib90_sieve_plugin.so) failed: /usr/lib/dovecot/lda/lib90_sieve_plugin.so: undefined symbol: tried_default_save
    Apr 14 14:07:06 server deliver(XXXX): Fatal: Couldn't load required plugins
    Apr 14 14:07:06 server postfix/pipe[4518]: 4F6CBD07DD: to=<XXXX>, relay=dovecot, delay=0.03, delays=0.01/0/0/0.01, dsn=4.3.0, status=deferred (temporary failure)
    Apr 14 14:07:06 server amavis[4158]: (04158-02) Passed CLEAN, [62.149.158.28] [80.180.218.82] <my_good_email_on_gmail> -> <XXXX>, Message-ID: <4DA6E1DB.4090308my_host_email>, mail_id: 4Q+HWBDgFMAt, Hits: 3.556, size: 19302, queued_as: 4F6CBD07DD, 464 ms
    Apr 14 12:07:06 server postfix/smtp[4512]: D3ABDD07DA: to=<XXXX>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.51, delays=0.03/0/0.01/0.47, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=04158-02, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 4F6CBD07DD)
    Apr 14 14:07:06 server postfix/qmgr[4117]: D3ABDD07DA: removed

    this si dovecot -n
    # 1.1.20: /etc/dovecot.conf
    # OS: Linux 2.6.18-238.5.1.el5 i686 CentOS release 5.6 (Final) ext3
    log_timestamp: %Y-%m-%d %H:%M:%S
    login_dir: /var/run/dovecot/login
    login_executable(default): /usr/libexec/dovecot/imap-login
    login_executable(imap): /usr/libexec/dovecot/imap-login
    login_executable(pop3): /usr/libexec/dovecot/pop3-login
    first_valid_uid: 5000
    last_valid_uid: 5000
    first_valid_gid: 5000
    last_valid_gid: 5000
    mail_location: maildir:/var/vmail/%d/%n/Maildir
    mail_executable(default): /usr/libexec/dovecot/rawlog /usr/libexec/dovecot/imap
    mail_executable(imap): /usr/libexec/dovecot/rawlog /usr/libexec/dovecot/imap
    mail_executable(pop3): /usr/libexec/dovecot/rawlog /usr/libexec/dovecot/pop3
    mail_plugins(default): quota imap_quota
    mail_plugins(imap): quota imap_quota
    mail_plugins(pop3): quota
    mail_plugin_dir(default): /usr/lib/dovecot/imap/
    mail_plugin_dir(imap): /usr/lib/dovecot/imap/
    mail_plugin_dir(pop3): /usr/lib/dovecot/pop3
    lda:
    postmaster_address: postmaster@example.com
    mail_plugins: sieve quota
    mail_plugin_dir: /usr/lib/dovecot/lda
    auth_socket_path: /var/run/dovecot/auth-master
    auth default:
    mechanisms: plain login
    passdb:
    driver: pam
    passdb:
    driver: sql
    args: /etc/dovecot-sql.conf
    userdb:
    driver: passwd
    userdb:
    driver: sql
    args: /etc/dovecot-sql.conf
    socket:
    type: listen
    client:
    path: /var/spool/postfix/private/auth
    mode: 432
    user: postfix
    group: postfix
    master:
    path: /var/run/dovecot/auth-master
    mode: 384
    user: vmail
    plugin:
    quota: maildir
    sieve_dir: ~/sieve


    I think that problem is this line
    Apr 14 14:07:06 server deliver(XXXX): dlopen(/usr/lib/dovecot/lda/lib90_sieve_plugin.so) failed: /usr/lib/dovecot/lda/lib90_sieve_plugin.so: undefined symbol: tried_default_save

    but i can't resolve it, and i can't find solutions on Google :(

    anyone can help me ?!

    Thanks
    Z.
     
  2. ZIZU

    ZIZU New Member

    All Done !!!

    i updated dovacat and now working ;)

    yum clean all
    yum update

    now is working ;)

    Bye
     
  3. saptaru

    saptaru New Member

    Solution?

    Hi, Can you please let us know how did you exactly managed to solve it ? Did you update dovecot from what repository ? I am really searching for a solution as my repositories says everything is up to date and no updates are available.

    And if anyone knows how to switch back to the previous version of dovecot ... At this moment I am having Version 1.2.17.

    Any help is appreciated !!!
     
  4. mike_p

    mike_p New Member

Share This Page