Dovecot cannot start at boot

Discussion in 'Server Operation' started by MaxT, Jun 19, 2018.

Tags:
  1. MaxT

    MaxT Member

    Dovecot cannot start at boot. Mail log shows this error after boot:

    Code:
    # tail -f /var/log/mail.log
    Jun 19 10:09:53 host postfix/smtpd[3126]: warning: SASL: Connect to private/auth failed: Connection refused
    Jun 19 10:09:53 host postfix/smtpd[3126]: fatal: no SASL authentication mechanisms
    Jun 19 10:09:54 host postfix/master[2224]: warning: process /usr/lib/postfix/smtpd pid 3126 exit status 1
    Jun 19 10:09:54 host postfix/master[2224]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
    emails cannot be delivered, and I'm forced to restart Dovecot manually: #service dovecot restart , and then it works.

    Just I have tried a dovecot update preserving my configuration. Maybe some unexpected change?
    I'm with Debian Jessie

    Some idea why it happens?.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Your system uses systemd, right?
     
  3. MaxT

    MaxT Member

    yes
    I can start manually. This is the status of dovecot (after start manually):
    Code:
    # systemctl -l status dovecot
    ? dovecot.service - Dovecot IMAP/POP3 email server
       Loaded: loaded (/lib/systemd/system/dovecot.service; disabled)
       Active: active (running) since mar 2018-06-19 11:45:26 CEST; 28min ago
     Main PID: 3585 (dovecot)
       CGroup: /system.slice/dovecot.service
               +-3585 /usr/sbin/dovecot -F
               +-3587 dovecot/anvil
               +-3588 dovecot/log
               +-3590 dovecot/config
               +-3595 dovecot/auth
               +-6183 dovecot/ssl-params
    
    jun 19 12:12:24 host.myhost.com dovecot[3588]: pop3-login:....
    
    thanks for the help :)

    Is this a systemd issue?
     
    Last edited: Jun 19, 2018
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    If I interpret this line correctly, then dovecot is disabled in systemd. Try to enable it:

    systemctl enable dovecot.service
     
  5. MaxT

    MaxT Member

    oh... I have checked the services before with sysv-rc-conf and 2,3,4,5 were active for dovecot. It was useless I suposse.

    After doing #systemctl enable dovecot.service error is finished and problem solved

    thank you! :)
     

Share This Page