Dovecot auth-worker error after cram-md5 auth

Discussion in 'Server Operation' started by Poliman, Jan 30, 2017.

  1. Poliman

    Poliman Member

    I set up cram-md5 using this tutorial https://wiki2.dovecot.org/HowTo/CRAM-MD5 in /etc/dovecot/dovecot.conf in passdb code block:
    listen = *,[::]
    protocols = imap pop3
    #auth_mechanisms = plain login cram-md5
    auth_mechanisms = cram-md5 plain login
    #dodana nizej linia
    ssl = required
    disable_plaintext_auth = yes
    log_timestamp = "%Y-%m-%d %H:%M:%S "
    mail_privileged_group = vmail
    postmaster_address = postmaster@vps342401.ovh.net
    ssl_cert = </etc/postfix/smtpd.cert
    ssl_key = </etc/postfix/smtpd.key
    ssl_protocols = !SSLv2 !SSLv3 !TLSv1 !TLSv1.1
    ssl_cipher_list = ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-AES256-GCM-SHA384:DHE-RSA-AES128-GCM-SHA256:DHE-DSS-AES$
    ssl_prefer_server_ciphers = yes
    ssl_dh_parameters_length = 2048


    mail_max_userip_connections = 100
    passdb {
    # args = /etc/dovecot/dovecot-sql.conf
    # driver = sql
    driver = passwd-file
    args = scheme=cram-md5 /etc/dovecot/cram-md5.pwd
    }
    userdb {
    driver = prefetch
    }
    userdb {
    args = /etc/dovecot/dovecot-sql.conf
    driver = sql
    }
    Of course I created cram-md5.pwd file. All mails go out and come nicely. But after I want to do default settings by commented out these two lines:
    driver = passwd-file
    args = scheme=cram-md5 /etc/dovecot/cram-md5.pwd
    and uncomment
    # args = /etc/dovecot/dovecot-sql.conf
    # driver = sql
    I can't send emails - I use Thunderbird - get error "logging on server mail.example.com not work out". Error in logs:
    dovecot: auth-worker(22698): Error: Auth worker sees different passdbs/userdbs than auth server.
    dovecot: auth: Error: read(anvil-auth-penalty) failed: EOF

    Is it possible that hashed password from cram-md5.pwd file was written to database (if yes then where - I have ISPconfig)? I wasn't change any userdb {} block and this second userdb block has this same lines like default settings in passdb block.
     

Share This Page