Dont know how its running..

Discussion in 'Server Operation' started by Wired_Eyed, Mar 14, 2010.

  1. Wired_Eyed

    Wired_Eyed New Member

    Ok, well im all square-eyed now, spent far too much time on this when it should be easy apparently, haha..

    Im hosting 2 websites and and using no-ip for simplistic reasons
    one of them has email..

    i followed this guide here
    Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Fedora 12 x86_64)

    First problems first....

    followed the guide to the T but adjusted where required due to only being i686.

    Problem arises here @ section

    "16 Populate The Database And Test"

    followed the guide and was told to do the following...

    INSERT INTO `users` (`email`, `password`, `quota`) VALUES ([email protected]', ENCRYPT('secret'), 10485760);
    MySQL spits our the following
    ERROR 1054 (42S22): Unknown column 'quota' in 'field list'
    no idea whats wrong there or where to start looking to fix


    Second problem

    no-ip handles the domains external dns for other internet users to find and view and email to.

    issue is the bind dns problem which is totally wacked...
    let me explain..

    i have 3 pc's, 1 is a server - others are browsing & gaming machines...

    server has 2 nic's in it..
    other details are as follows = adsl2+ router

    server pc = eth1 - goes to the router = eth0 - goes to network switch

    browsing pc

    gaming pc

    with the gateway & dns for the internal pc's being = eth0

    I have routing sorted, kinda...

    internal network pc's can say browse the 2 hosted sites - but not the internet.
    The server pc cannot browse the net either

    what i cannot figure out for the life of me is how to use bind correctly..
    or howto configure resolve.conf and hosts etc..

    basically i want the internal pc's to use as the dns & Gateway &
    if they visit either of the hosted domains

    they are routed to that and not to the web then back to my router login..

    I also still want the internal pc's of course to browse the web too though..

    Some more information incase its a simple error

    eth0 Link encap:Ethernet HWaddr 00:02:44:67:9E:8B
    inet addr: Bcast: Mask:
    inet6 addr: fe80::202:44ff:fe67:9e8b/64 Scope:Link
    RX packets:84047 errors:0 dropped:0 overruns:0 frame:0
    TX packets:81387 errors:0 dropped:0 overruns:0 carrier:0
    collisions:6034 txqueuelen:1000
    RX bytes:7183332 (6.8 MiB) TX bytes:11576500 (11.0 MiB)
    Interrupt:10 Base address:0x6000
    eth1 Link encap:Ethernet HWaddr 00:04:5A:6A:29:40
    inet addr: Bcast: Mask:
    inet6 addr: fe80::204:5aff:fe6a:2940/64 Scope:Link
    RX packets:14934 errors:0 dropped:0 overruns:0 frame:0
    TX packets:16016 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:6973047 (6.6 MiB) TX bytes:2577524 (2.4 MiB)
    Interrupt:11 Base address:0xe000
    lo Link encap:Local Loopback
    inet addr: Mask:
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:1890 errors:0 dropped:0 overruns:0 frame:0
    TX packets:1890 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:205230 (200.4 KiB) TX bytes:205230 (200.4 KiB)

    Destination Gateway Genmask Flags Metric Ref Use Iface complex.example UG 0 0 0 eth1 * U 0 0 0 eth1 * U 0 0 0 eth0
    default UG 0 0 0 eth1
    options {
    directory "/etc";
    pid-file "/var/run/named/";
    zone "" {
    type master;
    file "/var/named/";
    zone "" {
    type master;
    file "/var/named/";
    zone "." {
    type hint;
    file "/var/named/db.cache";
    # hostname added to /etc/hosts by anaconda localhost.localdomain localhost localhost
    ::1 localhost6.localdomain6 localhost6
    # Generated by NetworkManager
    # No nameservers found; try putting DNS servers into your
    # ifcfg files in /etc/sysconfig/network-scripts like so:
  2. falko

    falko Super Moderator ISPConfig Developer

    Apparently something went wrong when you created the users table:

    CREATE TABLE users (
    email varchar(80) NOT NULL,
    password varchar(20) NOT NULL,
    quota bigint(20) DEFAULT '10485760',
    PRIMARY KEY (email)
    ) TYPE=MyISAM;
    Do you have phpMyAdmin installed? Please check if the quota column exists.

Share This Page