domains not working!

Discussion in 'General' started by rokimoki, Apr 11, 2010.

  1. rokimoki

    rokimoki New Member

    Hello,
    I'm new here I've just installed ispconfig3 in debian5 and it looks so nice to be free ! congratulations devs.

    I have problem when I try to add a site, I add first a client, then add a site with assosiated to the client created, and I add in domain field "domain.com" with CGI (FastCGI), SSI, SuEXEC with auto subdomain "www." and activated.

    So it should work, I add the site, I restart apache, then I upload my site with the ftp (I create a ftp user too assosiated to my client site) so everything is seems to be ok.

    Once uploaded I type in my browser http://domain.com or http://www.domain.com and prompt me here "/var/www" instead of "/var/www/clients/client4/web4/web"

    What's wrong?
    Thanks.
     
    Last edited: Apr 11, 2010
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please add the IP address of your server in the ispconfig server settings and then select this IP address in the website settings instead of *.
     
  3. rokimoki

    rokimoki New Member

    eh

    I took the freedom to take a screenshot:
    [​IMG]

    So, I have the IP there, should be a different IP for each domain?

    Thanks.
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    The website works fine, If I enter the domain http://www.skynova.es/, the correct index document if the website is shown.
     
  5. rokimoki

    rokimoki New Member

    Nope because I have this:
    [​IMG]

    And is showing the main index.html created by default...
     
  6. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Then the files have been uploaded to the wrong website. Check the path of the website in the vhost file.
     
  7. rokimoki

    rokimoki New Member

    I know, the path /var/www/skynova.es is linked to /var/www/clients/client4/web4/web
     
    Last edited: Apr 11, 2010
  8. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please look into the vhost file as I suggested.
     
  9. rokimoki

    rokimoki New Member

    ehm

    Okay I maybe didn't understand you, where is the vhost file?
     
  10. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    That may vary. Normally you find it in /etc/apache2/sites-enabled or /etc/httpd/sites-enabled/
     
  11. rokimoki

    rokimoki New Member

    Thanks, I found in /etc/apache2/sites-enabled/skynova.es.vhost, this is a part of the file:
    Code:
        <Directory /var/www/skynova.es/web>
            Options FollowSymLinks
            AllowOverride Indexes AuthConfig Limit FileInfo
            Order allow,deny
            Allow from all
            
            # ssi enabled
            AddType text/html .shtml
            AddOutputFilter INCLUDES .shtml
            Options +Includes
        </Directory>
        <Directory /var/www/clients/client4/web4/web>
            Options FollowSymLinks
            AllowOverride Indexes AuthConfig Limit FileInfo
            Order allow,deny
            Allow from all
            
            # ssi enabled
            AddType text/html .shtml
            AddOutputFilter INCLUDES .shtml
            Options +Includes
        </Directory>
    EDIT:
    I uploaded well as you can see in my previous screenshot, what's wrong? :(
     
    Last edited: Apr 11, 2010
  12. rokimoki

    rokimoki New Member

    Now I got from nothing this error in apache server:
    Code:
    ks366912:~# /etc/init.d/apache2 start
    Starting web server: apache2[Mon Apr 12 09:57:54 2010] [warn] VirtualHost 94.23.21.18:80 overlaps with VirtualHost 94.23.21.18:80, the first has precedence, perhaps you need a NameVirtualHost directive
    [Mon Apr 12 09:57:54 2010] [warn] VirtualHost 94.23.21.18:80 overlaps with VirtualHost 94.23.21.18:80, the first has precedence, perhaps you need a NameVirtualHost directive
    [Mon Apr 12 09:57:54 2010] [error] VirtualHost _default_:443 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
     failed!
    I don't know why crashed and can't start....
     

Share This Page