DomainKey setup with Postfix and MailScanner

Discussion in 'HOWTO-Related Questions' started by chuenyang, Mar 5, 2008.

  1. chuenyang

    chuenyang New Member

    Anyone managed to setup Domainkeys for Mailscanner with Postfix as the MTA?

    I tried to setup using dk-milter. Followed the instructions to setup for dk-milter on Postfix.

    Everything is fine until I try to send emails out. The messages get stucked at the "hold" area and MailScanner doesn't seem to deliver them to the recipients.

    Any clues would be greatly appreciated!
     
  2. topdog

    topdog Active Member HowtoForge Supporter

    Does it work with out the milter as the placing messages in the hold queue is the way postfix operates with Mailscanner, it would seem to me that it is Mailscanner that is not picking up the messages from the hold queue and scanning them
     
  3. chuenyang

    chuenyang New Member

    Problem only with milter

    Yes, it worked perfectly for months until i installed the milter.

    In postfix's main.cf, including these 2 lines caused the problem with MailScanner:

    smtpd_milters = unix:/var/run/dk-milter/dk.sock
    non_smtpd_milters = unix:/var/run/dk-milter/dk.sock
     
  4. topdog

    topdog Active Member HowtoForge Supporter

    Okay give me a couple of days let me investigate the issue.
     
  5. topdog

    topdog Active Member HowtoForge Supporter

    It seems like MailScanner fails to handle the file due to the signed signature headers, i will investigate further as i need to look at the source to see where the error is originating from.
     
  6. chuenyang

    chuenyang New Member

    Tough one

    So it seems that the solution is not so straight-forward. I saw some domainKeys / SendMail integration techniques. Will applying a similar technique work here?
     

Share This Page