domain_username instead of web[WEBID]_username

Discussion in 'Tips/Tricks/Mods' started by HackerJL, Jul 19, 2006.

  1. HackerJL

    HackerJL New Member

    Example: has a user james

    currently i have the option of web1_whateveriwant

    Can I change the global option to be domain_whateveriwant

    currently under Management->system config->settings->ISP config tab it is:

    I dont know the string, but could it be something along the lines of:


    or what are the arguements allowed here?
  2. TheRudy

    TheRudy ISPConfig Developer ISPConfig Developer

    Not really, that is something that i would also like to see in ISPconfig, instead of static prefixes, you would have domain name prefixes where its possible, like mysql and so on..

    You can put whatever you want instead of 'web'[WEBID]_ but it will always be the same for all users..

    Your prefix + [WEBID]

    No other way..
  3. till

    till Super Moderator Staff Member ISPConfig Developer

  4. TheRudy

    TheRudy ISPConfig Developer ISPConfig Developer

    Hey, i didn't know that..

    [domain] = users domain.tld not the main/server domain?
    [host] = hostname?

    what happens, if i'm using [webid] currently and i change it to [domain]? Will everything be changed or will those accounts that have [webid] die as in not working anymore? :)
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    If you have a website, then:

    [HOST] = www
    [DOMAIN] =

    Existing usernames where not affected by that change.
  6. agbert

    agbert New Member

    This does not seem to work for the User Prefix as indicated. I set User Prefix to '[domain]_'. When adding a user/email the system returns an error: "Field: Username The user name has to contain a minimum of 4 and a maximum of 32 letters or figures and has to begin with a letter." The domain I am working with plus '_' plus the username itself is not >32 chars, so this must be an error due to using [domain].


  7. HackerJL

    HackerJL New Member

    I tried this on an existing server that is running. I changed it to [domain]_

    I made a domain called

    and added a user. It gave me a user of testdomain.com_jimmybobusername and it let me.

    I dont know what you were putting for the username part...
  8. agbert

    agbert New Member

    '' is the domain and andrewg is the username. Which should net me agbert.net_andrewg.

  9. agbert

    agbert New Member

    Attached is the screen shot for the add user form. Maybe something else is wrong because I would expect agbert.org_ to appear not [domain]_.


    Attached Files:

  10. HackerJL

    HackerJL New Member

    make sure in your settings its set the [DOMAIN]_ not [domain]_

    I just tried it again and this is what I am seeing.
  11. agbert

    agbert New Member

    Yup, that did it!

    Thank You!
  12. jockstrap

    jockstrap New Member

    wow - all that seems too complecated for me..

    I took it away completely and have the user simply make a name in the
    format initial.surname much easier for them as well...

    If there is a clash, well they just pick a slight variation..
  13. agbert

    agbert New Member

    Well, yes. That is what I have ended up doing as well. I had been browsing and found the setting interesting, and decided to try. The rest is history.
  14. actiononline

    actiononline New Member

    I tried this tonight on my server and found it was working fine for me. The only thing was that it still kept adding the domain number to the usernames. Even with this, it much easier identifying user activity in the logs when you can identify the domain extention.

    It helped me a great deal anyway!
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    When there is no "[WEBID]" in the prefix string, then no ID is added to the username.

Share This Page