domain with "-" on the name will not display

Discussion in 'Installation/Configuration' started by ladymariu, Feb 25, 2006.

  1. ladymariu

    ladymariu New Member

    Hello there :)
    We started using ispconfig at our new server and we have successfully transferred all our domains except for one that looks like:
    The only difference from the others is that "-" minus at the middle of the name.
    :confused: Any ideas why we get : Server not found error?
    Many thanks,
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    I Have many domains with "-" in the name, never got a problem with that.

    The server not found error is DNS related. Please check with "digg" if your domain already points to the correct IP address.
  3. falko

    falko Super Moderator ISPConfig Developer

    The command is
    (only one g :) ).
  4. DaddyFix

    DaddyFix New Member

    I also have a domain name with a minus sign. It never gets added to the Vhosts_ISPConfig.conf. Is there a quick fix for this?

    Here is more information I have

    Server Information
    Mandriva 2005 LE
    Apache 2.0.53
    PHP 5.0.23
    ISPConfig 2.2.7
    Error Messages in /home/admispconfig/ispconfig/ispconfig.log
    22.10.2006 - 15:50:44 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2414: WARNING: could not httpd -t  &> /dev/null
    22.10.2006 - 15:50:44 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2425: httpd syntax seems to contain errors, reloading with old configuration
    22.10.2006 - 15:50:44 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 2426: mv -f /etc/httpd/2.0/conf/vhosts/Vhosts_ispconfig.conf /etc/httpd/2.0/conf/vhosts/Vhosts_ispconfig.conf_22-10-06_15-50-44
    22.10.2006 - 15:50:44 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 2427: mv -f /etc/httpd/2.0/conf/vhosts/Vhosts_ispconfig.conf~ /etc/httpd/2.0/conf/vhosts/Vhosts_ispconfig.conf
  5. DaddyFix

    DaddyFix New Member

    I just found out that the error is generated by APACHE 2.0.53.

    apachectl configtest
    Checking configuration sanity for Apache 2.0:  Syntax error on line 307 of /etc/httpd/2.0/conf/vhosts/Vhosts_ispconfig.conf:
    LogFormat takes 1-2 arguments, a log format string (see docs) and an optional format name
    Here's The new custom logformat from Apache2
    # CustomLog with explicit format string
    CustomLog /var/log/httpd/my_site.com_access_log "%h %l %u %t '%r' %>s %b '%{Referer}i' '%{User-agent}i'"
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    This is not a custom log directive from ISPConfig. ISPConfig splits the mail logfile automatically with a script because custom log directives scale very bad and you might run out of file descriptors when you have more websites.
  7. falko

    falko Super Moderator ISPConfig Developer

    Please post line 307 from /etc/httpd/2.0/conf/vhosts/Vhosts_ispconfig.conf.

Share This Page