Domain/Website Quota problem

Discussion in 'Installation/Configuration' started by Nap, Dec 19, 2014.

  1. Nap

    Nap Member

    In ISPConfig3.0.5.4p5, the "Website Harddisk Quota" summary reports that my sites have unlimited Soft & Hard limits. Which is not correct. Mailbox quotas are correct though.

    I have my fstab configured as follows:
    # /etc/fstab: static file system information.
    # Use 'blkid' to print the universally unique identifier for a
    # device; this may be used with UUID= as a more robust way to name devices
    # that works even if disks are added and removed. See fstab(5).
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc        /proc        proc    defaults                       0 0
    UUID=f706775b-9e66-4978-95de-2a61ac14aab1   /            ext4    noatime,errors=remount-ro,usrjquota=quota.user,,jqfmt=vfsv0      0 1
    /dev/xvdb   none         swap    sw                             0 0
    /var/log/ispconfig/httpd/domain1.tld /var/www/clients/client0/web1/log    none    bind,nobootwait,_netdev    0 0
    /var/log/ispconfig/httpd/domain2.tld /var/www/clients/client1/web2/log    none    bind,nobootwait,_netdev    0 0
    /var/log/ispconfig/httpd/domain3.tld /var/www/clients/client2/web3/log    none    bind,nobootwait,_netdev    0 0
    /var/log/ispconfig/httpd/domain4.tld /var/www/clients/client3/web5/log    none    bind,nobootwait,_netdev    0 0
    /var/log/ispconfig/httpd/domain5.tld /var/www/clients/client3/web7/log    none    bind,nobootwait,_netdev    0 0
    I notice the ispconfig lines all end with 0 0. That doesn't seem right.

    For example, domain3.tld:

    In the Sites-> Website -> domain3.tld:
    Harddisk Quota: 500MB
    Traffic Quota: 400MB

    In Client -> domain3.tld Owner -> Limits:
    Web Limits
    Web Quota: 200MB
    Traffic Quota: 400MB
    Email Limits
    Mailbox Quota: 10MB

    Why the mismatch? Have I not configured something, or something's not running?

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The quota report is the output of:

    repquota -avu

    check if the quota is set there. If not, then it might be that quota in fstab has been adde dafter the websites were configured, you can then use the ispconfig resync function to force the website config to be rewritten which will also write out the quota valuaes again.

    The log mountpoints in fstab file are not related to quota.
  3. Nap

    Nap Member

    repquota -avu reported that 0 was used.
    I think I forgot to run (from the guide):
    quotacheck -avugm
    quotaon -avug
    So the usage is now being calculated.

    However, for one of my users (web5), the reported usage is more than double what it actually is (even after including database usage).

    Initially I didn't realise you meant the resync option in ISPConfig Tools page, so I ran 'quotasync -uga', but the usage is still overstated for that one user. I've resynced as well, but nothing changed.

    Users web5 and web7 are actually the same client. Could it be that web7 usage is being rolled into web5? This doesn't explain the numbers exactly, but it brings them much closer.

    I'm still trying to figure this out, because web5 is over its their limit at the moment, even after pruning files.

    Also, after running 'repquota -avg', the soft and hard limits for the CLIENTs are 0 (even after the resync).

    Last edited: Dec 20, 2014

Share This Page