Domain - server name in webinterface

Discussion in 'Installation/Configuration' started by francoisPE, Sep 15, 2021.

  1. francoisPE

    francoisPE Member HowtoForge Supporter

    Hello,
    I have ISPC3.2.6 multiple server with ubuntu20.04
    I set a domain through API : php cli connected on ns3 (ns3 is the one hosting web interface... not obvious !)

    It shows this
    upload_2021-9-15_16-53-23.png
    I didn't create that domain on ns3.
    I create on mail1
    this is what web interface shows
    upload_2021-9-15_16-54-25.png
    I check inside my server.
    ls /var/vmail is empty on ns3,
    ls /var/vmail contains client6.fr on mail1.

    I don't understand first panel showing ns3...
    I suspect dovecot to be incorrect because I can't connect with roundcube.

    I use that function and params
    Code:
    $mail_id = $client->mail_domain_add($session_id, $client_id, $params);
        $params = array(
        'server_id' => $CONFIG['server_id'],
        'domain' => $CONFIG['domain'],
        'active' => 'y',
        );
    
    Server_id is correct (mail1) as shown by 2nd picture and verified on server.

    What is incorrect in my process ?
    what does that function : $domain_id = $client->domains_domain_add($session_id, $client_id, $params); ?
     
    Last edited: Sep 15, 2021
  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    If you add a mail domain via the ui does it have the same issue, or does it display correctly? What does the mail_domain entry look like for an entry inserted each way?

    According to the api docs, 'Adds a new domain.' Ie. it inserts a row in the domain table.
     
  3. francoisPE

    francoisPE Member HowtoForge Supporter

    I try to things :
    - create domain with my scrip from mail1 server : same behavior ns3 on first panel
    - create manually. It gives :
    upload_2021-9-15_18-48-2.png
    mail1 as expected and not ns3 as above...
     
  4. francoisPE

    francoisPE Member HowtoForge Supporter

    I look in mariadDB it gives :
    upload_2021-9-15_19-23-50.png

    I don't understand what `domain` table is, but seems not to be usefull in my case as it is empty in mariaDB
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    test.fr was inserted on server2 and not 1, so you must have passed 2 as server_id.
     
    ahrasis likes this.
  6. francoisPE

    francoisPE Member HowtoForge Supporter

    My apologies.
    I found my mistake : script error leading to $server_id=1 :(

    Can you explain what `domain` table is for ?
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Domain limit module/function (See System > Interface> main config)
     
    ahrasis and francoisPE like this.
  8. francoisPE

    francoisPE Member HowtoForge Supporter

    thanks a lot :)
     

Share This Page