Domain Resolving to Router

Discussion in 'General' started by briand0713, Dec 9, 2017.

  1. briand0713

    briand0713 New Member


    I am running ISPConfig 3.1 on Ubuntu 17.10 (new install).
    I setup a client and DNS for my domain. I used the nameservers provided to me from my domain's DNS registrar.

    When I put or into a webbrowser, it automatically takes me to my router's login page instead of the ISPConfig default client index.html

    I followed this guide when setting up both Ubuntu and ISPConfig

    I was wondering what I need to do to fix this so that my will resolve to the client.

    Thanks :)
  2. ahrasis

    ahrasis Active Member

    Either use your router port forwarding or put your server on DMZ.
  3. briand0713

    briand0713 New Member

    sigh.... can't believe I forgot about Port Forwarding :( THANKS!!!!!!!!!!

    So I opened the ports on my router for my server. Now when I try to connect to through a webbrowser, I get Connection Time Out. Any idea why this is happening and how to fix the problem?

  4. adamjedgar

    adamjedgar Member

    What is the brand and model of your router?

    Outline the procedure you went through to port forward...exactly what did you do?

    Also, does your server have a static or dynamic local network ip address?

    Finally...and this probably should be external dns lookup is returning your home/office static ip address yes?
    Dont forget, its best to contact your internet service provider/phone company and have them assign you a static ip address for the connection to your address if you intend to run a webserver from the premises. Often this costs additional money per month on your phone/internet bill
  5. briand0713

    briand0713 New Member

    The Modem/Router was provided by the internet service provider. I think the IP is Dynamic however it's been a couple years now since the last time it actually changed.

    I had started out by reserving a local ip on the router (ie: I also assigned the IP to the server in the server config files.

    I am able to connect locally to the server through SSH (Can't through WinSCP for some reason and causes some sort of weird connection crash). Unable to connect through actual IP/ even with Port 22 open.

    For the Router, I went to Port Forwarding and opened 21,22,25,587,110,995,143,80 for for TCP/UDP.
    I also enabled DMZ for

  6. ahrasis

    ahrasis Active Member

    Dynamic or static ip does not matter if you cinfigured it right. I myself am using dynamic ip for my server.

    Try this:
    1. Only use either DMZ or port forwarding and not both at the same time.
    1. Access your website locally by first editing your OS host file e.g. add domain.tld in it and open domain.tld in your preferred browser. Try to ssh to it locally as well.
    3. If both is working and accessible locally, then check your public ip and try accessing from that ip.
    4. If step 2 is not working check your apache worker settings as well as ssh.

Share This Page