Domain redirects to unrelated domain for no reason

Discussion in 'General' started by Dark Magician, Aug 7, 2019.

  1. Dark Magician

    Dark Magician New Member


    I have setup a new server following the guideline (like i always do) to see if I could migrate to Debian 10.
    Now everything is working fine expect one domain.
    When I change the DNS records to point to my server it doesn't show the default landing page (the apache one) instead it shows the first website on the list of ISPconfig.
    I know it's confusing so I try to explain.

    I have which has a website on ISPconfig and all works well.
    I have which doesnt have a website on ISP config and it shows the default landing page.
    Then comes which also doesn't have a website and this shows

    There are no subdomains or aliasdomainssetup and is for client 1 and is for client 4. All unrealted to each other.It's a brand new server with only 5 domains (at the moment, since I stopped when I noticed this happenening) and I can't seem to fix it.
    I tested with a few new domains, pointed them to the server and it shows the default landing page. I deleted the website, rebooted, cleared cache and tried everything but as soon as I point to this server it shows It refuses to show the default landing page or (when I add the website to ISPCONFIG) the content in the client/web folder.

    When I fill up the webfolder of (hoping it wouldn't show the landing page anymore) it still redirects to
    Again, there are no redirects what so ever setup in ISPCONFIG. I just uploaded a clean .html file to see if it shows anything if there was a website attached.
    Tried different extensions as well and all show the default landing page off the server (the var/www/ one) or the content that's uploaded. Just this one domain doesnt. It's not a special domain as well. No numbers or special characters used.

    I hope someone can help me find this issue because i'm beyond understanding what is happening.

    I just found out that when I go to it shows the landing page and when I go to it redirects to is not configured in ISPCONFIG whatsoever when this is happening.

    Just found out this happens with other domains as well. Seems like all HTTPS traffic gets redirected to the first website in ISPCONFIG if there is no domain/website configured. So when i force HTTP it shows the landing page when I force HTTPS it shows the first website of the first client.

    Double checked, all non configured domains visiting with HTTPS show the SSL certificate and contents of HTTP is working as intended by showing the landing page.

    Saw someone stating that if not all sites has * for IP that could cause the issue. Double checked and all Domains have * as IP address

    It's getting weirder by the day... I just Disabled the first domain on the list (to see what happens) and now all HTTPS visits from non configured domains show the second website on the list...
    Last edited: Aug 7, 2019

Share This Page