Domain/port problems :(

Discussion in 'Installation/Configuration' started by badgerbox76, Jul 21, 2006.

  1. badgerbox76

    badgerbox76 Member

    I am unable to contact my server using http://www.monitorwaves.no-ip.org:443/ but http://monitorwaves.no-ip.org:443/ works. Also my isp blocks port 80 so i must use 443 or another port to contact the server. When i use http://monitorwaves.no-ip.org:443/ i get the server directory insted of the sites directory. This means that the php scripts will not run. So how can i fix ispconfig to take the requests of http://monitorwaves.no-ip.org:443/ and http://www.monitorwaves.no-ip.org:443/ to the right directory and run the php. Should i enable the create dns setting for the site?
     
  2. badgerbox76

    badgerbox76 Member

    I am sorry if i did not make my problem clear so i will try again.

    Problem 1) When i type the domain of my site http://monitorwaves.no-ip.org:443/ i get the servers directory not the sites index file.

    Problem 2) When i navigate to the sites directory the index page is opend in the browser but the php script idoes not run.

    Problem 3) I cant access the server when using http://www.monitorwaves.no-ip.org:443/ but can with http://monitorwaves.no-ip.org:443/ . The host is set to www and the domain is monitorwaves.no-ip.org so i dont know why i would be having this problem.

    I hope this makes things more clear, sorry if i have been hard to understand in the past :( Thanks for understanding.
     
  3. lipp9000

    lipp9000 New Member

    For problem 3, i had the same problem. My domain wasn't setup right.

    You need to make sure that when you create a new site, the hostname is set to www and the domain is set to yourdomain.com

    Then in order to get the domain without the www, you create a new co-domain and leave the hostname blank, and set the domain to yourdomain.com

    The hostname acts as like a subdomain for your master domain, that way your site will be www.yourdomain.com, then the co-domain is like a subdomain to that, but without the www.

    Try that, PHP scripts should work for both now.

    As for why your getting your server index instead of your web index I'm not sure, are you uploading to the web directory and deleting the index file thats set there by default?
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Can you post the vhost configuration from Vhosts_ispconfig and the output of
    Code:
    ifconfig
    here?


    www.monitorwaves.no-ip.org doesn't exist in DNS:

    Code:
    dig www.monitorwaves.no-ip.org
    
    ; <<>> DiG 9.2.1 <<>> www.monitorwaves.no-ip.org
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 41422
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;www.monitorwaves.no-ip.org.    IN      A
    
    ;; AUTHORITY SECTION:
    no-ip.org.              60      IN      SOA     nf1.no-ip.com. hostmaster.no-ip.com. 2017386901 18000 1800 604800 1800
    
    ;; Query time: 95 msec
    ;; SERVER: 81.169.163.104#53(81.169.163.104)
    ;; WHEN: Sat Jul 22 14:56:16 2006
    ;; MSG SIZE  rcvd: 104
    If there's no DNS record, it cannot work...
     

Share This Page