Domain point issue

Discussion in 'General' started by DizzyD, Mar 27, 2009.

  1. DizzyD

    DizzyD New Member

    I've just recently installed ISPconfig in Centos 5.2 and everything went smooth. However, I added a few 'sites' 3 to be exact but all domains point to the same directory, the first site that was created to be exact. I checked via webmin and viewed the virtual hosts and all directives were correct. I restarted apache just to be safe and even stopped and restarted but all to no avail. Any ideas?
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    1) Make sure that all domains point with a dns A-Record to the IP address of the server and that they dont use any kind of redirects.
    2) make sure that you selected this ip (the ip were the domains point to) in the website settings.
     
  3. DizzyD

    DizzyD New Member

    Thanks for the prompt reply. I have both * and www A Records pointing to the servers IP and the vhost file and directives have the correct ip settings as well, hence my confusion :(
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    When did you change the A Records? It may take ut to 48 hours until the changes are propagated to all dns servers.
     
  5. DizzyD

    DizzyD New Member

    I made the changes yesterday via my domain registrar. I know the changes took affect becuase the domain now points to my server. It just isn't pointing to its directory like it should. None of them are. I run several different servers so this isn't a totally new concept but when all my "i's" are dotted and my "T's" are crossed, it doens't make sense when it doesn't work.
     
  6. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Does all domains point to the first website you created in ispconfig or to which website they point?
     
  7. DizzyD

    DizzyD New Member

    Yes they point to the first site I created.
     
  8. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please try to set all sites to '*' in the site settings instead of the IP Address.
     
  9. DizzyD

    DizzyD New Member

    Still no avail....
     
  10. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Then I have no idea. Without knowing the exact domain names and vhost config files involved its just guessing.
     
  11. DizzyD

    DizzyD New Member

    directives for cleanprocanada.com
    Code:
        DocumentRoot /var/www/cleanprocanada.com/web
      
        ServerName cleanprocanada.com
        ServerAlias www.cleanprocanada.com
        ServerAdmin webmaster@cleanprocanada.com
    
        ErrorLog /var/log/ispconfig/httpd/cleanprocanada.com/error.log
    
        ErrorDocument 400 /error/400.html
        ErrorDocument 401 /error/401.html
        ErrorDocument 403 /error/403.html
        ErrorDocument 404 /error/404.html
        ErrorDocument 405 /error/405.html
        ErrorDocument 500 /error/500.html
        ErrorDocument 503 /error/503.html
    
        <Directory /var/www/cleanprocanada.com/web>
            Options FollowSymLinks
            AllowOverride Indexes AuthConfig Limit FileInfo
            Order allow,deny
            Allow from all
            
            # ssi enabled
            AddType text/html .shtml
            AddOutputFilter INCLUDES .shtml
            Options +Includes
        </Directory>
    
        # cgi enabled
        ScriptAlias  /cgi-bin/ /var/clients/client1/web2/cgi-bin/
        AddHandler cgi-script .cgi
        AddHandler cgi-script .pl
        # suexec enabled
        SuexecUserGroup web2 client1
        # php as fast-cgi enabled
        <Directory /var/www/cleanprocanada.com/web>
            AddHandler fcgid-script .php .php3 .php4 .php5
            FCGIWrapper /var/www/php-fcgi-scripts/web2/.php-fcgi-starter .php
            Options +ExecCGI
            AllowOverride all
            Order allow,deny
            Allow from all
        </Directory>
    
    yet it's its actually going to /var/www/all-starcleanpro.com/www which was the first site I set up in ispconfig. So i tried carpetcleaningbusiness.com and it too points to the same directory even though its' directives say it should be going elsewhere.
     
  12. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please post the complete vhost file, the first lines are missing.
     
  13. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

  14. DizzyD

    DizzyD New Member

    I suppose I should have mentioned that all-star doesn't point the server yet. But cleanprocanada does and so does carpetcleaningbusiness but both of them point to the directory that was made for all-star, if that makes sense.

    Basicly I created all-star first but then realized I wanted to make sure others work before I transfer it, so I created cleanprocanada.com and then carpetcleaningbusiness.com then pointed the domains to the server via A-records just like I do w/ other servers but then I found that both of them point to all-stars directory instead of their own.
     
  15. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Ok, then please post the two complete vhost files of these domains.
     
  16. DizzyD

    DizzyD New Member

    all-starcleanpro.com
    Code:
          DocumentRoot /var/www/all-starcleanpro.com/web
      
        ServerName all-starcleanpro.com
        ServerAlias www.all-starcleanpro.com
        ServerAdmin webmaster@all-starcleanpro.com
    
        ErrorLog /var/log/ispconfig/httpd/all-starcleanpro.com/error.log
    
        ErrorDocument 400 /error/400.html
        ErrorDocument 401 /error/401.html
        ErrorDocument 403 /error/403.html
        ErrorDocument 404 /error/404.html
        ErrorDocument 405 /error/405.html
        ErrorDocument 500 /error/500.html
        ErrorDocument 503 /error/503.html
    
        <Directory /var/www/all-starcleanpro.com/web>
            Options FollowSymLinks
            AllowOverride Indexes AuthConfig Limit FileInfo
            Order allow,deny
            Allow from all
            
            # ssi enabled
            AddType text/html .shtml
            AddOutputFilter INCLUDES .shtml
            Options +Includes
        </Directory>
    
        # cgi enabled
        ScriptAlias  /cgi-bin/ /var/clients/client1/web1/cgi-bin/
        AddHandler cgi-script .cgi
        AddHandler cgi-script .pl
        # suexec enabled
        SuexecUserGroup web1 client1
        # php as fast-cgi enabled
        <Directory /var/www/all-starcleanpro.com/web>
            AddHandler .php .php3 .php4 .php5
            Options +ExecCGI
            AllowOverride all
            Order allow,deny
            Allow from all
        </Directory>
    
    carpetcleaningbusiness.com
    Code:
    DocumentRoot /var/www/carpetcleaningbusiness.com/web
      
    ServerName carpetcleaningbusiness.com
        ServerAlias www.carpetcleaningbusiness.com
        ServerAdmin webmaster@carpetcleaningbusiness.com
    
        ErrorLog /var/log/ispconfig/httpd/carpetcleaningbusiness.com/error.log
    
        ErrorDocument 400 /error/400.html
        ErrorDocument 401 /error/401.html
        ErrorDocument 403 /error/403.html
        ErrorDocument 404 /error/404.html
        ErrorDocument 405 /error/405.html
        ErrorDocument 500 /error/500.html
        ErrorDocument 503 /error/503.html
    
        <Directory /var/www/carpetcleaningbusiness.com/web>
            Options FollowSymLinks
            AllowOverride Indexes AuthConfig Limit FileInfo
            Order allow,deny
            Allow from all
            
            # ssi enabled
            AddType text/html .shtml
            AddOutputFilter INCLUDES .shtml
            Options +Includes
        </Directory>
    
        # cgi enabled
        ScriptAlias  /cgi-bin/ /var/clients/client1/web4/cgi-bin/
        AddHandler cgi-script .cgi
        AddHandler cgi-script .pl
        # suexec enabled
        SuexecUserGroup web4 client1
    
    
    
     
  17. DizzyD

    DizzyD New Member

    any ideas? thanks again for helping :D
     
  18. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    This are not the complete files, the most interesting part is missing. the part with the IP addresses of the vhosts.
     

Share This Page