Domain name server - problems ... causes ?

Discussion in 'Installation/Configuration' started by Amorphous, Apr 13, 2011.

  1. Amorphous

    Amorphous New Member

    Hello, i have just installed ISPConfig 3.0.3.2 on a fresh Centos 5.5 operating system, and i have stumblled among some problems wth Bind and DNS creating ...

    I will start putting all the log bind creates, and after that all the config files regarding Bind, maybe u can explain what exactly is wrong :)
    first of all, in the tutorial it is specified in the named.conf

    I replaced

    with

    Also, in the "named" startup, i noticed that it asks for a /etc/named.conf file, so i created a link to /var/named/chroot/etc/named.conf


    These are all the config files:


    /var/named/chroot/etc/named.conf



    /var/named/chroot/var/named/named.local



    /var/named/chroot/var/named/pri.domain1.ro

    /var/named/chroot/var/named/pri.domain2.ro
    /var/named/chroot/var/named/pri.domain3.ro
    and so on, with all the other configs;

    Errors:

    all the other domains look the same.


    nslookup www.domain3.ro


    /etc/init.d/named restart

    As you see, no errors occur during restart named

    tail -f /var/log/messages

    i see in the nslookup command a problem at the end of the SERVFAIL error :
    a closer look
    why is this error in reading the domains ??? the domain2 is the "primary" domain,
    is the domain allocated in the /etc/hosts/ file .....
    and also in the resolv.conf

    all of these, as i explain to myself, seem to be fine, i really don`t understand what can i do, none of these settings don`t seem to raise up the domains, and at least 2 of them are very much needed, one of them being my network domain, all the others are personal domains also, using them for some friends with game and radio servers :).
    a quick reply with any possible ideea would be much appreciated :)

    Thank you very much !


    Later Edit:


    Thank You !
     
    Last edited: Apr 13, 2011
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The command dig domain3.ro tests external dns servers and not the local one, to test the local nameserver, use this command:

    dig @localhost dig domain3.ro

    The reason is that a dot at the ends of the domain is missing. Every fully qualified domain name has to end with a dot in dns.
     
  3. Amorphous

    Amorphous New Member

    this is the answer to the command dig

     
  4. Amorphous

    Amorphous New Member

    Still no change, still nothing....

    Any ideeas ? any suggestions ??? any thougts ??



    later edit .....

    maybe allow querry should be any instead of none ?

    and also listening should not be made by named also on the public ip and not only by localhost ?\

    I really am stucked here, on the previous instalation i used Centos 5.3 with ispconfig 3.0.2 .... with mydns installed and everythin worked perfect .... now .. i can t get my domains up ... and i don t know where is the problem ....
    except forwarding DNS servers for my internet clients i am totally away from any other settings for named and bind DNS servers ...
     
    Last edited: Apr 14, 2011
  5. falko

    falko Super Moderator ISPConfig Developer

    Please replace
    Code:
    options {
    listen-on port 53 { 127.0.0.1; };
    listen-on-v6 port 53 { ::1; };
    directory "/var/named/chroot/var/named";
    dump-file "/var/named/chroot/var/named/data/cache_dump.db";
    statistics-file "/var/named/chroot/var/named/data/named_stats.txt";
    memstatistics-file "/var/named/chroot/var/named/data/named_mem_stats.txt";
    allow-query { localhost; };
    recursion yes;
    };
    with
    Code:
    options {
    listen-on port 53 { [COLOR="Red"]any[/COLOR]; };
    listen-on-v6 port 53 { [COLOR="Red"]any[/COLOR]; };
    directory "/var/named/chroot/var/named";
    dump-file "/var/named/chroot/var/named/data/cache_dump.db";
    statistics-file "/var/named/chroot/var/named/data/named_stats.txt";
    memstatistics-file "/var/named/chroot/var/named/data/named_mem_stats.txt";
    allow-query { [COLOR="Red"]any[/COLOR]; };
    recursion yes;
    };
    in /var/named/chroot/etc/named.conf.
     
  6. Amorphous

    Amorphous New Member

    thank you very much, it work like a charm now :) if u can edit the tutorial also, u can try editing the tutorial for ispconfig centos 5.5, because all the commands and lines are copied exactly from the tutorial, and this erors i m sure i m not the only one with this problem,

    if u can help me with one more little problem i would appreciate very much your help....

    I want to make from this server also a DNS server for my Internet clients:
    In the personal settings for each client, i have now the Routing server as my primary DNS, and i want to make my Ispconfig server as my second DNS, and to forward my ISP DNS trough ....
    i know from the routing servers, that the config is somethig like this:

    how can i add a set of rules like this one, to my Ispconfig server so i can use also this server as a forwarder ??

    I know this is not the right section of the forum, but if u can help me with this little problem, i would appreciate it very much.

    Thank you again very much !!
     

Share This Page