Domain Name Error When Sending E-mail

Discussion in 'Installation/Configuration' started by yohon, Dec 30, 2006.

  1. yohon

    yohon New Member


    I am running a LAMP system on Fedora Core 6 installed using the following tutorial:

    I also have roundcube mail setup for webmail.
    There have been a couple of domains created on the server and web,dns, and incoming mail work just fine for them. I am able to access any sent e-mails using roundcube webmail.

    The problem is when I try to reply to e-mail in webmail, it will not work.
    The ISP's mail server is rejecting the e-mail saying that the domain name is incorrect. Judging by the logs, it looks like whoever the user is trying to send the e-mail, it is taking on @firestorm.localdomain as shown in the logs below. I would think it should be @domain.xx instead of the local server name for the mail to be sent. Maillog is show below.

    Would this be the problem as to why the ISP is rejecting the e-mail and is their a way to fix it through the ISPConfig control panel or is it manually editting files.

    Any help would be greatly appreciated. Thank you. Any other file config just let me know and I will post.

    Mail Log of error

    Dec 30 10:43:40 firestorm postfix/smtp[12584]: 98836B00B6: to=<[email protected]>,[]:25, delay=7980, delays=7980/0.04/0.14/0.13, dsn=4.0.0, status=deferred (host[] said: 450 <[email protected]>: Sender address rejected: Domain not found (in reply to RCPT TO command))
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    This is not a setting in ISPConfig, its a setting in roundcube. Please edit the email options and set the correct sender address.

    Also make sure, that the hostname of your server is correct, you can check the hostname with the commands.


    hostname -f

    A hostname like something.localdomain is not a valid hostname for sending mail.
  3. yohon

    yohon New Member

    This worked.

    Thank you Till.

Share This Page