Domain Help

Discussion in 'General' started by dclardy, Mar 4, 2010.

  1. dclardy

    dclardy Member

    All,

    I have had a ISPConfig system up for awhile, and I recently moved to a dedicated server. I have installed the release candidate of 3.0.2 on it.

    I have placed on the sites on it, and something is just not right. I have my main site. I placed it at the IP of the server. I can access that site at the IP and the domain name.

    The other sites can't be reached by just typing in their domain name. example.com.

    If I place the www., I can reach the sites just fine. Why is this? I would like to be able to reach the site without having to type the www. Any ideas on how to fix it?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You entered the domains with www in the domain field of the website settings, so you can reach the sites only with www in front. The correct way is to enter the domainname without www and then enable the auto subdomain www field, if the domain shall point with and wouthot www to this site.
     
  3. dclardy

    dclardy Member

    That is how I entered them.

    The domain name is alone in the domain field with an auto of www.

    Any other ideas?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    But then the result you describe is impossible from a technical standpoint. Please post the vhost file of this vhost.
     
  5. dclardy

    dclardy Member

    <Directory /var/www/drewclardy.info>
    AllowOverride None
    Order Deny,Allow
    Deny from all
    </Directory>

    <VirtualHost *:80>
    DocumentRoot /var/www/drewclardy.info/web

    ServerName drewclardy.info
    ServerAlias www.drewclardy.info
    ServerAdmin webmaster@drewclardy.info

    ErrorLog /var/log/ispconfig/httpd/drewclardy.info/error.log

    ErrorDocument 400 /error/400.html
    ErrorDocument 401 /error/401.html
    ErrorDocument 403 /error/403.html
    ErrorDocument 404 /error/404.html
    ErrorDocument 405 /error/405.html
    ErrorDocument 500 /error/500.html
    ErrorDocument 503 /error/503.html

    <Directory /var/www/drewclardy.info/web>
    Options FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>
    <Directory /var/www/clients/client1/web1/web>
    Options FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>

    # suexec enabled
    SuexecUserGroup web1 client1
    # php as fast-cgi enabled
    <IfModule mod_fcgid.c>
    SocketPath /tmp/fcgid_sock/
    IdleTimeout 3600
    ProcessLifeTime 7200
    MaxProcessCount 1000
    DefaultMinClassProcessCount 3
    DefaultMaxClassProcessCount 100
    IPCConnectTimeout 8
    IPCCommTimeout 360
    BusyTimeout 300
    </IfModule>
    <Directory /var/www/drewclardy.info/web>
    AddHandler fcgid-script .php .php3 .php4 .php5
    FCGIWrapper /var/www/php-fcgi-scripts/web1/.php-fcgi-starter .php
    Options +ExecCGI
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>
    <Directory /var/www/clients/client1/web1/web>
    AddHandler fcgid-script .php .php3 .php4 .php5
    FCGIWrapper /var/www/php-fcgi-scripts/web1/.php-fcgi-starter .php
    Options +ExecCGI
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>
    <Directory /var/www/clients/client1/web1/web>
    AddHandler fcgid-script .php .php3 .php4 .php5
    FCGIWrapper /var/www/php-fcgi-scripts/web1/.php-fcgi-starter .php
    Options +ExecCGI
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>

    # add support for apache mpm_itk
    <IfModule mpm_itk_module>
    AssignUserId web1 client1
    </IfModule>


    </VirtualHost>
     
  6. dclardy

    dclardy Member

    Maybe it has something to do with the DNS cacher that my job uses. Just tried it on my phone, and it appears to be working.
     

Share This Page