Domain has no DNS records

Discussion in 'Installation/Configuration' started by Hanz1711, May 5, 2021.

  1. Hanz1711

    Hanz1711 New Member

    Hi,

    after changing NS at domain registrator and after 24 hours, whois says that domain has no DNS records and Google Chrome say DNS_PROBE_FINISHED_NXDOMAIN.

    This is my setting in ISPConfig:
    upload_2021-5-5_12-5-28.png

    When I added the IP and domain to the hosts, the domain worked.
    ISPConfig version - 3.2.4
    NS1 and NS2 have A records on the servers where ISPconfig is installed.

    Where can be the problem, where do I start debugging?
    Thank you very much
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    There is DNS tutorial, link in my signature.
    If whois returns no name servers, the registration does not include name servers or they are not working. Check that first.
     
  3. Hanz1711

    Hanz1711 New Member

    Thank you for answer. I tried the settings according to the instructions, but unfortunately when trying the HOST command it reports:
    ns1, ns2: Host jednodusedetem.cz not found: 2 (SERVFAIL)
    main: It's okay here.

    Settings in ISPConfig:
    upload_2021-5-6_9-17-20.png
    ex. HOSTs:
    127.0.1.1 ns1.smidlonline.cz ns1
    # These lines are the same on every node:
    89.40.7.126 hosting.smidlonline.cz hosting
    94.176.234.139 ns1.smidlonline.cz ns1
    62.77.157.166 ns2.smidlonline.cz ns2

    # The following lines are desirable for IPv6 capable hosts
    ::1 localhost ip6-localhost ip6-loopback
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters

    Ping from ns1 to main - works

    Thans for help.
     

    Attached Files:

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Remove the two ns1 and ns2 A-records. A-Records for the NS records are only required if the NS records of the current zone are subdomains of the current zone, but that's not the case here as your NS records are from a different zone, that's why these A-Records may not be added.
     
  5. Hanz1711

    Hanz1711 New Member

    Thanks for help. I deleted the records, but still the host command on ns1 still can't find the domain.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Use the dig command to test the dns zone on ns1:

    dig @localhost yourdomain.tld

    replace yourdomain.tld with the domain name of the zone that shall be tested.
     
  7. Hanz1711

    Hanz1711 New Member

    Code:
    ***@ns1:~$ dig @localhost jednodusedetem.cz
    
    ; <<>> DiG 9.16.1-Ubuntu <<>> @localhost jednodusedetem.cz
    ; (2 servers found)
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 16906
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; OPT PSEUDOSECTION:
    ; EDNS: version: 0, flags:; udp: 4096
    ; COOKIE: ad3351bc06efe62c010000006093abce991af380500be6e0 (good)
    ;; QUESTION SECTION:
    ;jednodusedetem.cz.             IN      A
    
    ;; Query time: 416 msec
    ;; SERVER: ::1#53(::1)
    ;; WHEN: Thu May 06 11:41:50 EEST 2021
    ;; MSG SIZE  rcvd: 74
    
     
  8. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    According to whois the two name server for domain jednodusedetem.cz are:
    Code:
    $ whois  jednodusedetem.cz | grep nserver:
    nserver:      ns1.smidlonline.cz
    nserver:      ns2.smidlonline.cz
    
    However, those name servers know nothing about that domain:
    Code:
    $ host jednodusedetem.cz  ns1.smidlonline.cz
    ;; connection timed out; no servers could be reached
    [email protected] ~/Work/Python
    $ host jednodusedetem.cz  ns2.smidlonline.cz
    ;; connection timed out; no servers could be reached
    
    Are those two hosts name servers at all? Or is name service not running on them?
    Code:
    $ host ns1.smidlonline.cz ns2.smidlonline.cz
    ;; connection timed out; no servers could be reached
    [email protected] ~/Work/Pohjia
    $ host ns2.smidlonline.cz ns1.smidlonline.cz
    ;; connection timed out; no servers could be reached
    
     
  9. nhybgtvfr

    nhybgtvfr Well-Known Member HowtoForge Supporter

    he's probably changing something at the moment, they were responding earlier, albeit the jednodusedetem.cz zone still wasn't working.

    Code:
    $ nslookup jednodusedetem.cz ns1.smidlonline.cz
    Server:         ns1.smidlonline.cz
    Address:        94.176.234.139#53
    
    ** server can't find jednodusedetem.cz: REFUSED
    
    $ nslookup jednodusedetem.cz ns2.smidlonline.cz
    Server:         ns2.smidlonline.cz
    Address:        62.77.157.166#53
    
    ** server can't find jednodusedetem.cz: REFUSED
    
    i would suggest using named-checkconf and named-checkzone, to make sure there aren't any syntax errors in the bind config (named.conf, named.conf.local, and maybe named.conf.options), or in the jednodusedetem.cz zonefile.
    if nothing shows up there, try restarting bind and check /var/log/named/bind.log to see if the zonefile is getting loaded.
     
  10. Hanz1711

    Hanz1711 New Member

    Since this was the first domain on ISPConfig, I reinstalled all the servers once more according to the instructions and now it works. Hurrah. Probably there was a mistake somewhere between the keyboard and the chair. Thank you so much for your time and help.
     
    Th0m likes this.

Share This Page