Domain forwarding / redirect failed

Discussion in 'Installation/Configuration' started by stefanr, Mar 28, 2009.

  1. stefanr

    stefanr Member


    i upgraded my isp installation from version 2.2.29 to version 2.2.30. Befor i upgrade my domain forwarding from to works fine. After the upgrade my forwarding wan't work.

    Into the ispconfig the subdomain is defined but the

    cat /etc/apache2/vhosts/Vhosts_ispconfig.conf |grep


    RewriteEngine on
    RewriteCond %{HTTP_HOST} ^webmail\.domain\.de [NC]
    RewriteRule ^/(.*)$1 [L,R]
    RewriteCond %{HTTP_HOST} ^ispconfig\.domain\.de [NC]
    RewriteRule ^/(.*)$1 [L,R]

    it looks like my config in the ispconfig wrote the :81 not into the vhosts_ispconfig.conf

    thanks for your help.

  2. virtualweb

    virtualweb New Member

    Same Problem here

    As described in the Announcement for Version 2.2.30 i added one line of code to /root/ispconfig/scripts/lib/config.lib.php but even after restarting the server the ports are ignored.

    Has someone found a solution for this problem?

    SOLVED - it is working now as described with the modifications in config.lib.php
    Last edited: Mar 29, 2009
  3. stefanr

    stefanr Member

    thanks for your replay virtualweb,

    can you post me the modification of your /root/ispconfig/scripts/lib/config.lib.php

    kind regards

  4. falko

    falko Super Moderator ISPConfig Developer

  5. stefanr

    stefanr Member

    Hello Falko,

    thanks for your answer, i do an update to version 2.2.31 it fixed...



Share This Page