Domain/Directory problems

Discussion in 'Installation/Configuration' started by badgerbox76, Aug 8, 2006.

  1. badgerbox76

    badgerbox76 Member

    I am so sorry to be bothering the community once again with my problem that i cant seem to shake. I have created a domain at no-ip.com which is monitorwaves.no-ip.org (DNS A) and a port 80 redirect to port 443. In the ispconfig setup for the site i have www for the host and monitorwaves.no-ip.org for the domain, i also have dns selected. In addition to that i created another domain name for this site but i left the host blank and entered monitorwaves.no-ip.org for the domain. I dont reach the server at http://www.monitorwaves.no-ip.org/ but can at http://monitorwaves.no-ip.org/
    When i reach the server it takes me to the server's main directory not the sites. How can i fix this?

    I tryed to make it as clear as i could but if you dont understand what i said just ask me about it and i will try to clear things up. Thanks :)

    By the way falko you are the best! Thanks for letting me stay and be appart of the community
     
    Last edited: Aug 8, 2006
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    If you registered monitorwaves.no-ip.org at no-ip.com, then you must create a website:

    host: monitorwaves
    domain: no-ip.org

    beacuse www.monitorwaves.no-ip.org is another domain name then monitorwaves.no-ip.org/
     
  3. badgerbox76

    badgerbox76 Member

    I have change the sites domain to Host:monitorwaves Domain:no-ip.org but i am still getting the servers main index. I have created a domain at no-ip.org which is moniorwaves.no-ip.org

    Here is my setup
    [img=http://img279.imageshack.us/img279/8837/ispconfigrn1.th.jpg]

    what els should i try?

    Would you like to my setup a user account?
     
  4. falko

    falko Super Moderator ISPConfig Developer

    What's in Vhosts_ispconfig.conf? What's the output of
    Code:
    ifconfig
    ?
     
  5. badgerbox76

    badgerbox76 Member

    Here is my ifconfig output
    [email protected]:~$ ifconfig
    ath0 Link encap:Ethernet HWaddr 00:0D:88:C7:45:E6
    inet addr:192.168.0.105 Bcast:192.168.0.255 Mask:255.255.255.0
    inet6 addr: fe80::20d:88ff:fec7:45e6/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:88253 errors:490443 dropped:0 overruns:0 frame:490443
    TX packets:6600 errors:72 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:200
    RX bytes:31755756 (30.2 MiB) TX bytes:3578760 (3.4 MiB)
    Interrupt:10 Memory:d0980000-d0990000

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:2805 errors:0 dropped:0 overruns:0 frame:0
    TX packets:2805 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:177344 (173.1 KiB) TX bytes:177344 (173.1 KiB)

    [email protected]:~$

    Am i just stupid or is there a problem with ispconfig?
     
  6. falko

    falko Super Moderator ISPConfig Developer

    What's in Vhosts_ispconfig.conf?
     
  7. badgerbox76

    badgerbox76 Member

    I see that ispconfig's is lisening on port 80, how can i change it to port 443? Do i need to remove port 80 form the apache portlist config file. Thanks

    Vhosts_ispconfig.conf
    Code:
    ###################################
    #
    # ISPConfig vHost Configuration File
    #         Version 1.0
    #
    ###################################
    #
    NameVirtualHost 192.168.0.105:80
    <VirtualHost 192.168.0.105:80>
      ServerName localhost
      ServerAdmin [email protected]
      DocumentRoot /var/www/sharedip
    </VirtualHost>
    #
    #
    ######################################
    # Vhost: monitorwaves.no-ip.org:80
    ######################################
    #
    #
    <VirtualHost 192.168.0.105:80>
    ServerName monitorwaves.no-ip.org:80
    ServerAdmin [email protected]
    DocumentRoot /var/www/web4/web
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Defau$
    ErrorLog /var/www/web4/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    <Files *.php>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php3>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php4>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php5>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    php_admin_flag safe_mode Off
    Alias /error/ "/var/www/web4/web/error/"
    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /var/www/web4/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web4/user/$1/web/$3
    </VirtualHost>
    #
    #
    #
    
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    No, just enable the "SSL" checkbox in the settings of the website and then create a SSL certificate on the SSLtab in the website settings.
     
  9. falko

    falko Super Moderator ISPConfig Developer

    When I go to monitorwaves.no-ip.org in my browser, my browser wants to redirect me to http://70.34.184.212:443/, and then I get this in Firefox:

    I guess 70.34.184.212 is your public IP address, but monitorwaves.no-ip.org is pointing to 204.16.252.98:

    Code:
    dig monitorwaves.no-ip.org
    
    ; <<>> DiG 9.2.1 <<>> monitorwaves.no-ip.org
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 25842
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;monitorwaves.no-ip.org.                IN      A
    
    ;; ANSWER SECTION:
    monitorwaves.no-ip.org. 60      IN      A       204.16.252.98
    
    ;; Query time: 102 msec
    ;; SERVER: 81.169.163.104#53(81.169.163.104)
    ;; WHEN: Fri Aug 11 17:26:48 2006
    ;; MSG SIZE  rcvd: 56
    You must change the DNS record of monitorwaves.no-ip.org so that it points to 70.34.184.212 otherwise you'll never get this thing working.
     
  10. badgerbox76

    badgerbox76 Member

    Here are the screenshots of my dns and port redirect setup at no-ip.org
     

    Attached Files:

  11. falko

    falko Super Moderator ISPConfig Developer

    That's what I'm trying to tell you all the time: redirects don't work. You must change the A record so that it points to your public IP address. Remove this "Port 80 redirect".
     
  12. badgerbox76

    badgerbox76 Member

    GREAT!!! For some resone my isp has opened up port 80!!!! so i no longer need a port redirect. http://monitorwaves.no-ip.org/ Try it out!!!THANKS THANKS THANKS!

    OK last problems, my domains :( I can only reach my site at http://monitorwaves.no-ip.org/ not http://www.monitorwaves.no-ip.org/

    Here is how i have my domains set up

    Domain 1
    Hostname:monitorwaves
    Domain:no-ip.org

    Domain 2
    Hostname:www
    Domain:monitorwaves.no-ip.org

    why can i still not reach the site at the www address?
     
    Last edited: Aug 12, 2006
  13. falko

    falko Super Moderator ISPConfig Developer

Share This Page