Does the SPAM-Filter works for forwarded mails?

Discussion in 'General' started by Pay87, Apr 18, 2017 at 12:27 PM.

  1. Pay87

    Pay87 New Member

    Hi ISPConfig community,
    I struggle with a SPAM problem for some time now. I have a "perfect Ubuntu server" with latest ISPConfig 3.1.2.
    - I activated Graylisting on all mailboxes.
    - SPAM-Filter is set to Normal mode (it seems to mark a lot of SPAM mails quite well with *** SPAM *** Tags), but not all.
    - I added some RBL servers to the config through ISPConfig fields, like zen.spamhaus.org
    - I added some blacklisted mail addresses to the "Postfix global ispconfig settings", and I also added individual rules for some mailboxes, like "if message comes from [email protected] -> discard".

    I need to forward a lot of "virtual mail addresses" to real mailboxes from domain names like [email protected] or [email protected] to [email protected]. I use ISPConfig to setup the forwarding addresses.

    Now here I think is a problem. If mail e.g. comes from [email protected] to "virtual address" and then gets forwarded to real mailbox, the rules seem not to work. Even global filters seem not to work and I am not sure about RBL or SPAM-Filter too. Is there something I miss? I get around 30-50 SPAM message all from forwarded addresses right now ... :(

    Thanks!
     
  2. Pay87

    Pay87 New Member

  3. till

    till Super Moderator Staff Member ISPConfig Developer

    The post you found is about a different software (ISPConfig 2 and not 3), it is not related in any way to your ISPCnfig 3 setup.

    To apply spamfilter policies to redirects as well, ensure to set the policy on domain level and not just in the mailbox. Or alternatively, create own rules for the forwards under Spamfilter > user/domain. But using the domain level setting is easier.
     
    Pay87 likes this.
  4. Pay87

    Pay87 New Member

    Hi till, this is what I checked:
    - Policy for @domain.tld inside user/domain is set to "Normal" already, but with priority 5 instead 10.
    - Policy for E-Mail Domain is also set to "Normal" already for domain.
    So I guess I missed something else ...

    /Edit:
    I also added now for the forwarded adresses a record inside user/domain. Default priority is 5, but mailboxes have 10, so I let default option active. Also "Local" Option is set to yes. Maybe the records will help ... :)
     
    Last edited: Apr 19, 2017 at 4:30 PM

Share This Page