Does PHP 5.2 work as alternativ php-version?

Discussion in 'Installation/Configuration' started by vistree, Mar 25, 2013.

  1. vistree

    vistree Member

    Hi, I tried to setup php 5.2.17 on a ispconfig 3.0.5.1 with php 5.3 as default (debian squeeze).
    I used this tutorial as reference:
    http://www.howtoforge.com/building-php-5.4-from-source-on-debian-squeeze

    During compinling I got a note, that --enable-intl is an unknown option.
    The rest was fine.

    Now, when I activate fast-cgi -> 5.2.17 for an old drupal site (which displays fine with 5.3 but brings php5.3 incomp. errors) the web renders an error 500.
    Debugging is hard and the only hint I find is the following error (error.log):
    Code:
    [Mon Mar 25 13:04:28 2013] [warn] [client XX.XXX.XX.XXX] (104)Die Verbindung wurde vom Kommunikationspartner zur├╝ckgesetzt: mod_fcgid: error reading data from FastCGI server
    [Mon Mar 25 13:04:28 2013] [error] [client XX.XXX.XX.XXX] Premature end of script headers: index.php
    
    Is there anything special on php 5.2?
     
  2. vistree

    vistree Member

    Last edited: Mar 27, 2013
  3. falko

    falko Super Moderator ISPConfig Developer

    Please note that you cannot use PHP 5.2 as PHP-FPM with ISPConfig because the FPM configuration had a different syntax prior to PHP 5.3.
     

Share This Page