Does Not Work: Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMai

Discussion in 'HOWTO-Related Questions' started by aic71, Mar 17, 2010.

  1. aic71

    aic71 New Member

    I've followed the instructions completely.. I'm not able to get any of my users to now login.

    I get the following in my /var/log/mail.log:

    Mar 13 19:05:38 kaylee imapd: Connection, ip=[::ffff:127.0.0.1]
    Mar 13 19:05:38 kaylee imapd: LOGIN FAILED, [email protected], ip=[::ffff:127.0.0.1]
    Mar 13 19:05:43 kaylee imapd: LOGOUT, ip=[::ffff:127.0.0.1], rcvd=72, sent=332

    The user exists in the database and has the correct password.

    Help!
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Which distribution do you use?

    What are the outputs of
    Code:
    grep achernow /etc/passwd
    and
    Code:
    grep achernow /etc/aliases
    ?
     
  3. aic71

    aic71 New Member

    Debian Lenny I believe is what's on the box.

    Do those matter if I've theoretically got the email server set up to use virtual users? The account 'achernow' already exists as a system user anyway, since that's what I'm using to log into the box.

    Code:
    [email protected]:~$ sudo grep achernow /etc/aliases
    [sudo] password for achernow: 
    [email protected]:~$ sudo grep achernow /etc/passwd
    achernow:x:1000:1000:achernow,,,:/home/achernow:/bin/bash
    [email protected]:~$ 
    
    The username exists, as I said, in the mail database as well:

    [​IMG]

    This is getting really annoying... I can get EVERYTHING else to work except for e-mail. It's like you need to be a rocket scientist or something to configure it.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    But why do you go the hard route then by configuring everything manually? It is much easier if you use a controlpanel like ispconfig where you just have to enter the email domain and address and which configures postfix for you?

    http://www.howtoforge.com/perfect-server-debian-lenny-ispconfig3
     
  5. falko

    falko Super Moderator ISPConfig Developer

    That is exactly the problem. When you send an email to [email protected], it gets delivered to the system user achernow instead of the virtual user [email protected], which means the Maildir of [email protected] isn't created, and that's why you can't log in.
     
  6. aic71

    aic71 New Member

    [strike]So if I create the maildir it should be ok?[/strike]

    Never mind. I re-read the part of the tutorial where you said to add the user and mail it. It seems to work from an IMAP client now...but Squirrelmail goes to a white screen after it logs in...no inbox. Not sure why.

    I've had bad experiences with control panels. I'm on a sever that a friend configured right now that Error 500's every time I try to do ANYTHING in the control panel. Also it's made it hard to tweak Apache config files and php.ini files since it'll overwrite them with no notice.
     
    Last edited: Mar 19, 2010
  7. falko

    falko Super Moderator ISPConfig Developer

    Please make sure you introduced no PHP syntax error when you edited the config.php file of the change_sqlpass plugin.
     

Share This Page