"does not list name servers"

Discussion in 'General' started by atakacs, Jun 6, 2010.

  1. atakacs

    atakacs New Member

    Hi

    pretty new to myDNS so I might be overlooking something obvious...

    I have setup my first "live" primary DNS and it seems to work rather well.

    However running an external DNS tester I get an error to the effect that my server does not list name servers:

    WARNING: At least one of your nameservers did not return your NS records (it reported 0 answers). This could be because of a referral, if you have a lame nameserver (which would need to be fixed).

    xxx.xxx.xxx.xxx returns 0 answers (may be a referral)

    I am pretty sure I have defined NS records for my zone... why would my server not return them ?

    Any help / pointer appreciated

    Regards

    alex
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Is your nameserver autoritative for the domain? You can find that out by running
    Code:
    dig ns yourdomain.com
     
  3. atakacs

    atakacs New Member

    Hi

    Thanks for your help

    It would seem I have no authorative server. How do I fix this (the authorative server would be the one managed by myDnsConfig ?!

    Regards

    alex
     
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    You can set an authoritative nameserver in the control panel of your domain registrar. In this case it should be your MyDNS server.
     
  5. atakacs

    atakacs New Member

    thanks - that's what I thought and I believe that's what I did... Will check with the registar to see what's up with them.

    Regardss
     

Share This Page