does not answer

Discussion in 'General' started by trexen, Mar 17, 2010.

  1. trexen

    trexen Member

    I have done installation om debian Lenny, and all works fine, and use another server to resolv.

    A have a test and i have point the domain to my servers IP address, and configure mydnsconfig to act as a master DNS for my i have put up a web server and mail server om another IP.

    If i try dig and nslookup i got no response from the server, im sure my router i configure correctly.

    i have no ide whats wrong and cant fint any error messages i the log files.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post a screenshot of the domain settings in mydnsconfig for this test domain (the first tab and the records tab).
  3. trexen

    trexen Member


    as requested

    This DNS server has IP .60 at the end.

    Attached Files:

    Last edited: Mar 17, 2010
  4. trexen

    trexen Member


    as requested2

    Attached Files:

  5. till

    till Super Moderator Staff Member ISPConfig Developer

    The zone tab is ok.
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    You missed to add a dot at the end of the fully qualified domains names. In mydns and BIND, records that contain a fully qualified domain have to end with a dot.

    The zone tab is ok.
  7. trexen

    trexen Member


    it this the correct settings?

    Attached Files:

  8. till

    till Super Moderator Staff Member ISPConfig Developer

    No. You missed to add the dots in the fqdn's in the data field. Something like is a fqdn (fully qualified domain name) and a fqdn has to end with a dot. So it must be and

    If you have relative records like "www", there is no dot at the end.

    For example, your current MX record points to as it is currently a relative record and not a absolute.

    I guess what you want is that emails for gets delivered to the server, the record for that will be:

  9. trexen

    trexen Member


    yes you right, i hope i correctmy mistakes

    Attached Files:

  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Better but not fully correct. Please see what I posted above for the mx record. Data must be and not mail. Otherwise you would be able to get only emails for but I guess you want to get emails for

    The ns record is fine.
  11. trexen

    trexen Member


    just to be clear, so i understand you and the DNS =)

    Attached Files:

  12. till

    till Super Moderator Staff Member ISPConfig Developer

    Looks good now.
  13. trexen

    trexen Member

    not workin

    Hi again!

    Now that i know that MyDNSConfig is correctly configured, i try to connect to the web server pointing to my ispconfig 2.2.35 server holding but no answer, i try dig and nslookup

    trexen@mDNS:~$ dig ns

    ; <<>> DiG 9.5.1-P3 <<>> ns
    ;; global options: printcmd
    ;; connection timed out; no servers could be reached

    trexen@mDNS:~$ nslookup
    ;; connection timed out; no servers could be reached

    i talked to the company that have my and everything looks fine, they just forward my domain to my server (DNS)

    i have no idea whats wrong.
    port 53, 8080 are open and a ssh port, im able to telnet on port 53 so its working.

    plz help
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    If you changed the Nameserver of a domain, you have to wait up to 48 hours.

    The dig command above does not query your local dns server, it querys any dns server. If you want to test if your local dns server is configured correctly, run the command:

    dig @localhost
  15. trexen

    trexen Member

    same problem

    Hi again.

    I got no answer from my DNS server from the Internet, it answer correctly when i run "dig @localhost"

    but if i run nslookup i got no answer (cant find the domain)

    plz help =)
  16. zepx

    zepx New Member


    check port 53. Is it opened? If you have your firewall off, and yet port 53 does not respond, it means that BIND is not listening to port 53. I'm also facing this problem at the moment.

    EDIT: I've solved my problem.

    I'm using Ubuntu 9.10

    1. First use "netstat -an" without quotes and check and see if exists. I found out that it's using which was not correct.
    2. I changed /etc/bind/named.conf.options and had it looked something like below,

    options {
            directory "/var/cache/bind";
            // If there is a firewall between you and nameservers you want
            // to talk to, you may need to fix the firewall to allow multiple
            // ports to talk.  See [url][/url]
            // If your ISP provided one or more IP addresses for stable
            // nameservers, you probably want to use them as forwarders.
            // Uncomment the following block, and insert the addresses replacing
            // the all-0's placeholder.
            // forwarders {
            // };
            auth-nxdomain no;    # conform to RFC1035
            listen-on-v6 { ::1; };
            allow-recursion {
            query-source port 53;
    3. Restart BIND

    Last edited: Mar 26, 2010
  17. trexen

    trexen Member

    same same

    Hi, sorry by i dont got "Bind" installed this is "Installing MyDNS-NG & MyDNSConfig 3 On Debian Lenny" installation and say nothing about BIND

    I try netstat -an and it type med the correct IP:53 and

    i already got 3 public BIND servers and they works fine.

    I will go to MyDNSConfig if i get it to work but i got problems whit that =)

  18. zepx

    zepx New Member

    Ok fine, but I think by default all DNS servers listen at port 53. is not correct, and I don't think it will be answering any of your DNS Queries. Therefore, you need to make it to

    Figure it out for MyDNSConfig as even the latest ISPConfig has already started using BIND.
  19. trexen

    trexen Member

    same same same

    Hi again,

    I checkt my other BIND servers and none of them had only
    localIP:53 and

    i also got the latest stable version. and no luck =)
  20. zepx

    zepx New Member

    Then have you tried the link I gave you? Have you tried checking whether port 53 is blocked?

    Check them on all of your other servers as well. If they are opened, then it's really strange for me.

Share This Page