does ispconfig 5.0.3 supply php5.2.x php5.3.x php5.4.* at one time or on a ispconfig panle

Discussion in 'General' started by itlife365.com, Dec 5, 2015.

  1. itlife365.com

    itlife365.com New Member

    does ispconfig 5.0.3 supply php5.2.x php5.3.x php5.4.* at one time or on a ispconfig panle
     
  2. Jesse Norell

    Jesse Norell Active Member

    Ispconfig doesn't "supply" any php version, your OS does, but current ispconfig versions (ie. 3.0.5, not 5.0.3) should work with any of those (php 5.2, 5.3, or 5.4). There was recently a mention of dropping support for php5.2 for the upcoming ispconfig 3.1 release.

    For your websites you can install and configure (in ispconfig) multiple versions of php, and select which version a website uses. For instructions on that see "Using multiple PHP versions" at http://www.ispconfig.org/page/en/documentation.html
     
  3. itlife365.com

    itlife365.com New Member

    thank you ,i find it ,but after i install php 5.2.10 .
    i visit my website . error 500 appear .
    the apache error.log show below :
    [Tue Dec 08 20:29:37 2015] [warn] [client 112.5.170.111] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server
    [Tue Dec 08 20:29:37 2015] [error] [client 112.5.170.111] Premature end of script headers: test.php
    [Tue Dec 08 20:29:48 2015] [warn] [client 112.5.170.111] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server
    [Tue Dec 08 20:29:48 2015] [error] [client 112.5.170.111] Premature end of script headers: phpinfo.php

    does anyone help me ?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you check that the php binary that you compiled is working?
     

Share This Page