Does anyone know how to get the mail to work in ISPConfig 3?

Discussion in 'Installation/Configuration' started by midcarolina, Aug 6, 2011.

  1. midcarolina

    midcarolina New Member

    That's all there is to say. I've tried every suggestion. I have used two DNS (MX) records. One with domain registrar (which in my opinion TOTALLY defeats the purpose of even using ISPConfig), reconfigured /etc/hosts, reconfigured A records with MX records, you name it, it's been done. The mail system simply does not work.
     
  2. baicunko

    baicunko New Member

    Which distribution are you using? anithing on /var/log/maillog ?
     
  3. midcarolina

    midcarolina New Member

    I am using ISPConfig 3 on Fedora 14 x86_64 and there hasn't been anything showing problems in any mail logs, the "monitor" is all green light. I don't get it. Generally, I should be able to use mail.example.com on another mail server to get mail, like windows mail....doesn't work. Tried everything...Think I'm gonna scrap ISPConfig. It should serve as a stand alone DNS server, but it doesn't. You still need the domain registrar's DNS for it to even somewhat function. Not a real CP.
     
  4. baicunko

    baicunko New Member

    I don't know why you are using your domain registrar's DNS.
    I've built my own nameservers in ISPConfig 3 with no problem at all.
    http://www.howtoforge.com/how-to-run-your-own-name-server-with-ispconfig-3-and-fast-hosts
    Try that,
    then from the outer world do the following
    telnet YOURDOMAIN 25
    please upload your /var/log/maillog
     
  5. midcarolina

    midcarolina New Member

    I have tried this too. Not exactly as these directions. So, allow me to try this configuration and then submit my results. That is precisely what my entire goal has been from the start. Hopefully you will be able to respond to the result tomorrow? I really want to try this. I even tried using Google's global DNS IPs, 8.8.8.8, and 8.8.4.4 So, without divulging you exact IPs, how were you able to get a unique IP for each nameserver? Thanks for all your help.
     
  6. baicunko

    baicunko New Member

    I'm hosting my own nameserver in only one computer for now, If you want real redundancy then you should get another server but for now it's ok
    I've used godaddy and configured it like this.
    I told godaddy I've got my own nameserver
    ns1.domain.com
    ns2.domain.com
    both pointing at a certain IP
    Then on my PC created the CNAME and the A records as shown in the tutorial.
    After that you should try in terminal
    dig yourdomain.com
    and it should appear your ip.
    Tell me how it goes
     
  7. midcarolina

    midcarolina New Member

    I will, I have long since configured the ns1 and ns2 at GoDaddy, which was excepted just fine, it just didn't resolve for the additional (second) domain that I added. Also, a traceroute showed ns1 and ns2 going back to GoDaddy's ns71 and ns72 instead of the IPs I specifically placed in the nameserver creation, again perfectly accepted by GoDaddy. I called and they also confirmed that they were pointing to Google's Global DNS service. I'll try this and let you know what I come up with. Gotta get this fixed. I want ALL client users to use only my nameservers. Thanks again...will follow these instructions.
     
  8. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

  9. midcarolina

    midcarolina New Member

    Hi Falko,

    Do be honest with you, I now realize that I know FAR less about DNS than I thought I did. I believe it had something to do with the host companies making it easy on even those using VDS. The bottom line is that I want my clients to do what they currently do with my host reseller. They simple point their nameservers to mine, and the rest is handled on my end and my end alone. No need to deal with the domain registrars DNS EVER again. Only my nameservers, only my DNS. Here is the output of the command line you asked about (which shows one of Googles Global DNS, which is a good sign - even though it doesn't work!)

    Last login: Thu Aug 4 14:18:27 2011 from cpe-024-211-042-040.sc.res.rr.com
    [root@webserver ~]# dig mx hostwithsupport.com

    ; <<>> DiG 9.7.4b1-RedHat-9.7.4-0.3.b1.fc14 <<>> mx hostwithsupport.com
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 15340
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;hostwithsupport.com. IN MX

    ;; ANSWER SECTION:
    hostwithsupport.com. 3600 IN MX 0 mail.hostwithsupport.com.

    ;; Query time: 159 msec
    ;; SERVER: 8.8.8.8#53(8.8.8.8)
    ;; WHEN: Sun Aug 7 10:27:21 2011
    ;; MSG SIZE rcvd: 58

    Thanks, Bryan
     
  10. midcarolina

    midcarolina New Member

    Hey Falko,

    After doing this test, I decided to use Firefox's mail server, Thunderbird. It is recognizing the mail servers (imap, smtp, pop3) but it is also doing the exact same thing that GMail did when I tried to route it there. Every password that I use is not recognized??? So it can't accept incoming with IMAP or pop.
     
  11. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    You forgot to create an A record for mail.hostwithsupport.com:

    Code:
    mh1:~# dig mail.hostwithsupport.com
    
    ; <<>> DiG 9.3.4 <<>> mail.hostwithsupport.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 9875
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;mail.hostwithsupport.com.      IN      A
    
    ;; Query time: 1427 msec
    ;; SERVER: 213.133.98.98#53(213.133.98.98)
    ;; WHEN: Mon Aug  8 11:08:33 2011
    ;; MSG SIZE  rcvd: 42
    
    mh1:~#
    Just one small hint, Thunderbird is no mail server, it's a mail client.
     

Share This Page