Do not reply to potential spam

Discussion in 'Tips/Tricks/Mods' started by jmroth, Jan 30, 2008.

  1. jmroth

    jmroth ISPConfig Developer ISPConfig Developer

    I just read
    http://www.heise.de/ix/foren/S-Blacklist-Eintraege-durch-Bounces-vermeiden/forum-48292/msg-14324386/read/

    The following diff will help ISPConfig not autoresponding to potential spam (if SA is enabled) and ending oneself up in some blacklist, as mentioned in the artice.

    Code:
    --- autoresponder.rc.master.orig        2008-01-30 19:14:42.000000000 +0100
    +++ autoresponder.rc.master     2008-01-30 19:09:32.000000000 +0100
    @@ -11,6 +11,8 @@
                   | formail -rD 8192 {PFAD}/.vacation.cache
    
                     :0 ehc         # if the name was not in the cache
    +               * ! ^X-Spam-Flag: YES
    +               # don't autoreply to potential spam
                     | (formail -rI"From: {EMAIL_ADDRESS}" -I"Precedence: junk" \
                          -A"X-Loop: ${EMAIL}" ; \
                        cat {PFAD}/.vacation.msg \
    
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Thanks, I've added this to our To-Do list. :)
     
  3. falko

    falko Super Moderator ISPConfig Developer

    Added to SVN. :)
     

Share This Page