do not receive mail

Discussion in 'Installation/Configuration' started by Evert, Jun 10, 2006.

  1. Evert

    Evert New Member

    Hello

    i have fedora core 5

    I have followed up this howto:
    http://www.howtoforge.com/perfect_setup_fedora_core_5_p2

    imho i am sure that i have done everything that is mentioned

    my main.cf lookes like this:
    queue_directory = /var/spool/postfix
    command_directory = /usr/sbin
    daemon_directory = /usr/libexec/postfix
    mail_owner = postfix
    inet_interfaces = all
    myorigin = mail.winsucks.be
    #mydestination = $myhostname, localhost.$mydomain, localhost
    unknown_local_recipient_reject_code = 550
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases

    debug_peer_level = 2
    debugger_command =
    PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
    xxgdb $daemon_directory/$process_name $process_id & sleep 5

    sendmail_path = /usr/sbin/sendmail.postfix
    newaliases_path = /usr/bin/newaliases.postfix
    mailq_path = /usr/bin/mailq.postfix
    setgid_group = postdrop
    html_directory = no
    manpage_directory = /usr/share/man
    sample_directory = /usr/share/doc/postfix-2.2.8/samples
    readme_directory = /usr/share/doc/postfix-2.2.8/README_FILES
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtpd_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    message_size_limit = 10485760
    virtual_maps = hash:/etc/postfix/virtusertable
    mydestination = /etc/postfix/local-host-names

    i have a test domain .. www.winsucks.be
    i have created a user for this domain in ispconfig
    I am using thunderbird as mail client

    When i sent a message to this user from my main e-mail the message does never delivered.
    I do not get an error message in my main e-mail

    i have also created an MX and an A record in the dns section of the plesk at my hosting company

    winsucks.be. MX (0) mail.winsucks.be
    mail.winsucks.be. A my.ip.number

    here is an sample of the output of cat /var/log/maillog

    Jun 10 14:54:36 mail dovecot: POP3(web2_evert): pop3_uidl_format setting is missing from config file
    Jun 10 14:54:36 mail dovecot: pop3-login: Login: user=<web2_evert>, method=PLAIN, rip=::ffff:192.168.1.13, lip=::ffff:192.168.1.13
    Jun 10 14:54:36 mail dovecot: child 1499 (pop3) returned error 89
    Jun 10 14:54:54 mail dovecot: POP3(web2_evert): pop3_uidl_format setting is missing from config file
    Jun 10 14:54:54 mail dovecot: pop3-login: Login: user=<web2_evert>, method=PLAIN, rip=::ffff:192.168.1.13, lip=::ffff:192.168.1.13
    Jun 10 14:54:54 mail dovecot: child 1506 (pop3) returned error 89
    Jun 10 15:02:25 mail dovecot: POP3(web2_evert): pop3_uidl_format setting is missing from config file
    Jun 10 15:02:25 mail dovecot: pop3-login: Login: user=<web2_evert>, method=PLAIN, rip=::ffff:192.168.1.13, lip=::ffff:192.168.1.13
    Jun 10 15:02:25 mail dovecot: child 1678 (pop3) returned error 89

    what can be the problem
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Make sure you enabled Maildir under Management -> Server -> Settings -> Email in ISPConfig.
     
  3. hayroob

    hayroob New Member

  4. falko

    falko Super Moderator ISPConfig Developer

    Anything in your mail log? What'S the exact bounce message? Can you post your real domain name here to which you're sending?
     

Share This Page