DNSBL Timeout - mail subjects get rewritten

Discussion in 'Installation/Configuration' started by ivanhq, Oct 27, 2009.

  1. ivanhq

    ivanhq New Member

    Hello there.

    Every email I send from my ISPConfig 3 server (i.e. using Squirrelmail) gets its subject rewritten with this string. I.e:

    original subject: "hello there!"
    received subject: "[DNSBL Timeout]hello there!"

    This is happening to all incoming and outgoing emails. I've thought maybe it's because of some misconfiguration on amavis or spamassassing, but I can't find this string arount /etc/*...

    I'm using Debian Lenny, followed every step on the perfect setup howto, and one thing i've noticed is that I don't have a /etc/amavisd.conf file.

    Any help will be appreciated. Thanks in advance.

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Never seen this before, so its unlikely that this is caused by ispconfig. Please check that you do not run any other spam filtering software on your server and on the server that runs the recipient email.

    Try to send a email from squirrelmail to the same local address that you used to login to squirrelmail. Does the same appears in the title?
  3. ivanhq

    ivanhq New Member

    If i send and email from a hosted email account, to the same hosted email account, then it works well (no rewritten subject).
    For the rest, its ALWAYS rewrites subject.

    In the same rack, using the same IP range and the same gateway, I have an ISPConfig 2 working with no problems.

    I think it's maybe because of Net::DNS module or something not resolving correctly the RBL checks. This is why i've tried these steps:

    1) on /etc/mail/spamassassin/local.cf

    skip_rbl_checks 1

    2) on /etc/mail/spamassassin/v320.pre

    # commented this line for disabling the plugin
    # loadplugin Mail::SpamAssassin::plugin::DNSEval

    But it's stille rewriting subjects.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    I dont think that it gets rewritten by amavisd on this server as when you send a email to the same server then the subject is not modified. There must be some other software that is doing the rewrite which is not part of the ispconfig setup.

    If you really believe that its caused by amavis, then enable debugging in amavisd and check the mail log for the debug output.
  5. ivanhq

    ivanhq New Member

    You're right

    Hi again Till,

    You're right. Amavisd in debug mode does not show the RBL queries, so it necessarily has to be a middleware. I'll keep investigating...

    Thanx a lot for your time and help.


Share This Page