DNS_SOA mbox bug?

Discussion in 'Developers' Forum' started by jnewman67, Mar 25, 2021.

  1. jnewman67

    jnewman67 Member

    busy entering domains into my fresh ISPConfig 3.2.3 CentOS8 Perfect Server installation...

    under DNS -> Zone Settings, after using the Wizard, there are a couple of inconsistencies (i think...)

    1. the wizard asks for 2 name servers, but the zone map only allows for editing one of them, though both appear on the Records tab - shouldn't there be two here as well?

    2. the email field, entered as '[email protected]' in the wizard, is instead displayed as name.domain.tld (the @ is replaced). if i edit the email on the Zone Settings tab, and save it, and go back into it, it does the same thing. is that format correct? seems like that's wrong... if i put in [email protected], it becomes first.last.mail.domain.tld...
     
  2. jnewman67

    jnewman67 Member

    2 more things.

    the Sign zone (DNSSEC) checkbox in the wizard doesn't appear to get set either. If I go into the Zone Settings after finishing the wizard, all DNSSEC settings are unset.

    also, while editing Zone Settings after completing the Wizard, I mistakenly unset the Client field, and it allowed it to be saved - seems like that should be a required field (but maybe not - i may not see one of the reasons it should be allowed).
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    No.

    That's correct as it is now as well.

    If you like to learn more about how DNS works and why these things have to be like this, I'll recommend to read then docs of the BIND DNS server to learn how a zone file looks like and what it contains and how the notation for data is.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Signing a zone works fine here in ISPConfig 3.2.3 using the wizard.

    Selecting a client is optional in ISPConfig as any kind of record can be assigned to the admin directly as well.
     

Share This Page