Dns

Discussion in 'Installation/Configuration' started by alexis101, May 13, 2013.

  1. alexis101

    alexis101 New Member

    Im trying to configure my new installation of ISPConfig and the dns part cause me some problem. Here is the records of on of my zone :
    Code:
     
    	A 	mail 	XXX.XXX.XXX.XXX 	0 	3600 	
    	A 	ns1 	XXX.XXX.XXX.XXX  	0 	3600 	
    	A 	ns2 	XXX.XXX.XXX.XXX  	0 	3600 	
    	A 	domain.com. 	XXX.XXX.XXX.XXX  	0 	3600 	
    	A 	www 	XXX.XXX.XXX.XXX  	0 	3600 	
    	MX 	domain.com. 	mail.domain.com. 	10 	3600 	
    	NS 	domain.com. 	ns1.domain.com 	0 	3600 	
    	NS 	domain.com. 	ns2.domain.com 	0 	3600
    
    But when I try :
    Code:
    dig domain.com @127.0.0.1
    
    ; <<>> DiG 9.8.4-rpz2+rl005.12-P1 <<>>domain.com  @127.0.0.1
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 50199
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;domain.com.                   IN      A
    
    ;; Query time: 3391 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Mon May 13 12:14:17 2013
    ;; MSG SIZE  rcvd: 29
    Any Idea why when I try dig locally it gives me a Server Fail?
    Thank you
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Check the syslog file for named errors.
     
  3. alexis101

    alexis101 New Member

    Thanks I forgot to say that I did that.
    When i restart bind there is no error :
    Code:
    May 13 13:03:07 TAG-SERVER04 named[9820]: ----------------------------------------------------
    May 13 13:03:07 TAG-SERVER04 named[9820]: BIND 9 is maintained by Internet Systems Consortium,
    May 13 13:03:07 TAG-SERVER04 named[9820]: Inc. (ISC), a non-profit 501(c)(3) public-benefit
    May 13 13:03:07 TAG-SERVER04 named[9820]: corporation.  Support and training for BIND 9 are
    May 13 13:03:07 TAG-SERVER04 named[9820]: available at https://www.isc.org/support
    May 13 13:03:07 TAG-SERVER04 named[9820]: ----------------------------------------------------
    May 13 13:03:07 TAG-SERVER04 named[9820]: adjusted limit on open files from 4096 to 1048576
    May 13 13:03:07 TAG-SERVER04 named[9820]: found 1 CPU, using 1 worker thread
    May 13 13:03:07 TAG-SERVER04 named[9820]: using up to 4096 sockets
    May 13 13:03:07 TAG-SERVER04 named[9820]: loading configuration from '/etc/bind/named.conf'
    May 13 13:03:07 TAG-SERVER04 named[9820]: reading built-in trusted keys from file '/etc/bind/bind.keys'
    May 13 13:03:07 TAG-SERVER04 named[9820]: using default UDP/IPv4 port range: [1024, 65535]
    May 13 13:03:07 TAG-SERVER04 named[9820]: using default UDP/IPv6 port range: [1024, 65535]
    May 13 13:03:07 TAG-SERVER04 named[9820]: listening on IPv6 interfaces, port 53
    May 13 13:03:07 TAG-SERVER04 named[9820]: listening on IPv4 interface lo, 127.0.0.1#53
    May 13 13:03:07 TAG-SERVER04 named[9820]: listening on IPv4 interface eth0, 192.168.57.14#53
    May 13 13:03:07 TAG-SERVER04 named[9820]: generating session key for dynamic DNS
    May 13 13:03:07 TAG-SERVER04 named[9820]: sizing zone task pool based on 5 zones
    May 13 13:03:07 TAG-SERVER04 named[9820]: using built-in root key for view _default
    May 13 13:03:07 TAG-SERVER04 named[9820]: set up managed keys zone for view _default, file 'managed-keys.bind'
    May 13 13:03:07 TAG-SERVER04 named[9820]: Warning: 'empty-zones-enable/disable-empty-zone' not set: disabling RFC 1918 empty zones
    May 13 13:03:07 TAG-SERVER04 named[9820]: automatic empty zone: 254.169.IN-ADDR.ARPA
    May 13 13:03:07 TAG-SERVER04 named[9820]: automatic empty zone: 2.0.192.IN-ADDR.ARPA
    May 13 13:03:07 TAG-SERVER04 named[9820]: automatic empty zone: 100.51.198.IN-ADDR.ARPA
    May 13 13:03:07 TAG-SERVER04 named[9820]: automatic empty zone: 113.0.203.IN-ADDR.ARPA
    May 13 13:03:07 TAG-SERVER04 named[9820]: automatic empty zone: 255.255.255.255.IN-ADDR.ARPA
    May 13 13:03:07 TAG-SERVER04 named[9820]: automatic empty zone: 0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.IP6.ARPA
    May 13 13:03:07 TAG-SERVER04 named[9820]: automatic empty zone: 1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.IP6.ARPA
    May 13 13:03:07 TAG-SERVER04 named[9820]: automatic empty zone: D.F.IP6.ARPA
    May 13 13:03:07 TAG-SERVER04 named[9820]: automatic empty zone: 8.E.F.IP6.ARPA
    May 13 13:03:07 TAG-SERVER04 named[9820]: automatic empty zone: 9.E.F.IP6.ARPA
    May 13 13:03:07 TAG-SERVER04 named[9820]: automatic empty zone: A.E.F.IP6.ARPA
    May 13 13:03:07 TAG-SERVER04 named[9820]: automatic empty zone: B.E.F.IP6.ARPA
    May 13 13:03:07 TAG-SERVER04 named[9820]: automatic empty zone: 8.B.D.0.1.0.0.2.IP6.ARPA
    May 13 13:03:07 TAG-SERVER04 named[9820]: command channel listening on 127.0.0.1#953
    May 13 13:03:07 TAG-SERVER04 named[9820]: command channel listening on ::1#953
    May 13 13:03:07 TAG-SERVER04 named[9820]: zone 0.in-addr.arpa/IN: loaded serial 1
    May 13 13:03:07 TAG-SERVER04 named[9820]: zone 127.in-addr.arpa/IN: loaded serial 1
    May 13 13:03:07 TAG-SERVER04 named[9820]: zone 255.in-addr.arpa/IN: loaded serial 1
    May 13 13:03:07 TAG-SERVER04 named[9820]: zone localhost/IN: loaded serial 2
    May 13 13:03:07 TAG-SERVER04 named[9820]: managed-keys-zone ./IN: loaded serial 4
    May 13 13:03:07 TAG-SERVER04 named[9820]: running
    
    And if I do a tail -f while doing the dig nothing register in the syslog.
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please post the output of

    ls /etc/bind
     
  5. alexis101

    alexis101 New Member

    Code:
    ls /etc/bind
    bind.keys  db.127  db.empty  db.root     named.conf.default-zones  named.conf.options   pri.tag-consultation.com.err  slave
    db.0       db.255  db.local  named.conf  named.conf.local          pri.tag-com.net.err  rndc.key                      zones.rfc1918
    
     
  6. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    The domain file has a .err extension, this mens that the bind syntx check failed and the file was excluded from configuration. Pleaee post the content of the .err file.
     
  7. alexis101

    alexis101 New Member

    Code:
    cat  /etc/bind/pri.tag-com.net.err
    $TTL        3600
    @       IN      SOA     ns1.tag-com.net. admin.tag-com.net. (
                            2013051317       ; serial, todays date + todays serial #
                            7200              ; refresh, seconds
                            540              ; retry, seconds
                            604800              ; expire, seconds
                            86400 )            ; minimum, seconds
    ;
    
    mail 3600 A        144.76.39.122
    ns1 3600 A        144.76.39.122
    ns2 3600 A        144.76.39.122
    tag-com.net. 3600 A        144.76.39.122
    tag-com.net. 3600      MX    10   mail.tag-com.net.
    tag-com.net. 3600      NS        ns1.tag-com.net
    tag-com.net. 3600      NS        ns2.tag-com.net
    www 3600 A        144.76.39.122
    
     
  8. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Edit the two ns records of the zone in ispconfig and add the missing dots after:

    ns1.tag-com.net.

    and

    ns2.tag-com.net.
     
  9. alexis101

    alexis101 New Member

    How did I missed that :D
    Thanks a lot it works now
     
  10. sharkey

    sharkey New Member

    I have an error that only occurs on a .co extension.

    The .com domains work fine. The .co used it's own name as a nameserver.


    Code:
    $TTL        3600
    @       IN      SOA     ns1.XXXXXX.co. admin.XXXXXX.co. (
                            2013052301       ; serial, todays date + todays serial #
                            7200              ; refresh, seconds
                            540              ; retry, seconds
                            604800              ; expire, seconds
                            86400 )            ; minimum, seconds
    ;
    
    XXXXXX.co. 3600 A        XX.XX.XX.XX
    XXXXXX.co. 3600      MX    10   mail.XXXXXX.co.
    XXXXXX.co. 3600      NS        ns1.XXXXXX.co.
    XXXXXX.co. 3600      NS        ns2.XXXXXX.co.
    mail 3600 A        XX.XX.XX.XX
    www 3600 A        XX.XX.XX.XX


    To fix this I had to input the nameserver as IP address in ISPconfig instead of ns.xx.xx.xx.xx.co

    ETA, I see now I had to add the A record for NS1 and NS2.
     
    Last edited: May 23, 2013

Share This Page