DNS zones not transfered to slave server anymore

Discussion in 'Installation/Configuration' started by grungy, Mar 5, 2009.

  1. sonicscott

    sonicscott New Member

    MyDNS - MySQL 5.0.67

    Just so I am being clear, here is what I did:

    1) Changed the database table and the two PHP files as above

    2) Upgraded MyDNS

    After re-reading the above, I think I have successfully stepped on myself! :D

    *** UPDATE ***

    I ran the ISPCONFIG_UPDATE.SH file and updated to the latest ISPCONFIG version ( This changed the above PHP files back to what they originally were and changed the database field type back to ENUM. Now when I restart the bind9 server, in the syslog file I get 'Permission Denied' instead of 'Refused'.

    *** END OF UPDATE ***

    Last edited: May 27, 2009
  2. sonicscott

    sonicscott New Member

    With the above issue between MyDNS and Bind9, let me ask this:

    Is it possible to stop using MyDNS and install BIND on the ISPCONFIG server? I realize that I would have to manually create/edit the zone files instead of using the interface, but would this cause any other issues with ISPConfig?

  3. sonicscott

    sonicscott New Member


    Please ignore last message. Problem resolved.
  4. normc

    normc New Member

    Will this fix be included in upcoming releases of ISPConfig?
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    You will have to ask this the mydns developers, as its a bug in mydns and not ispconfig. And as ispconfig does not ship or change the mydns sources, they have to apply the fix in their sourcecode. See my posts in this thread to see why its a mydns bug and not ispconfig bug.

    Might ven be that its fixed already in mydns as this thread is old and there are newer mydns releases.
  6. rukus77

    rukus77 Member

    Installing mydns-ng will be your best bet if you want this issue resolved.

  7. normc

    normc New Member

    Thank you very much for your input and clarification.

    I have installed the MyDNS-ng binaries and I noticed that the DB schema is different from the MyDNS tables (dns_soa, and dns_rr). Will the ISPConfig DNS interface still work with the new MyDNS-ng table structure?

    Is it as easy as dropping the original mydns tables (dns_soa, and dns_rr) and replacing them with the MyDNS-ng tables of the same name (mydns --create-tables)?

    I have searched for a document online that explains this, but have not found one explaining this.

    Your help is appreciated.

    Thank you,
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig is compatible with mydns-ng, thats why we suggest to use it here.

    Do not modify any tables!
  9. u4david

    u4david New Member

    Dns Ispconfig3 assistance

    i would like to configure dns records on ispconfig3.
    This is one server operation (one server runs it all).I remember thought when installing that somewhere i used different names for mail server configuration and ns server configuration....
    Steps how to verify this naming would be helpful.
    My router have open porsts listed by ispconfig firewall.

    my registrar configuration is:
    mydomain.com > public ip is my static ip i replaced the last digits with 1 s to stay anonymous)
    mydomain.net >public ip

    I think that should be the only configuration that i will do using my registrar control panel.The rest should be done using Ispconfig3 correct?

    Right now my web pages on each of these domains load correctly using virtual host one ip.(tested load the correct page for each domain)

    Up to this point all works

    now i would like to configure dns using Ispconfig3
    that is a,mx,ns records.....
    mydomain.net will be the first one to configure it and test it.
    So lets concentrate just on this domain:

    so first add a zone:
    soa: u4server.net.
    NS: what to put here?how to verify the correct ns host name is used?
    email: what to put here?how to verify the correct host name is used?

    active is checked

    nex is to add the the records

    adding A ,mx,ns records first

    please advise how to add them
    what names to choose and how to verify that proper host names/sub domains are used. and adding appropriate IP.

    Is local IP used ar all IPs will pont to the public IP?
    if local IPs are used in some extend when and how?

    thank you for clarification.
    Last edited: Jan 5, 2010
  10. cyp25

    cyp25 New Member

    The field type in dns_soa table has to be VARCHAR and not INT to make it work.


  11. u4david

    u4david New Member

    More details

    I generally use the wizard and then go back to reconfigure some entries.

    But i would appreciate if you cold explain more in depth what is it that you mean.
  12. rukus77

    rukus77 Member

    Not necessarily true... When I had this issue (before switching to mydns-ng), INT worked fine for me on 3 different servers. This is running in a mydns (master) bind (slave) configuration.

  13. u4david

    u4david New Member

    all works-next to configure second server as a slave

    So i got my dns server up and running all works fine.

    Now i would like to set up slave server(home i got master at work i will have slave)

    Any steps on how to do that if both locations will run Ispconfig3?

Share This Page