DNS-zone doesn`t "lookup"

Discussion in 'Installation/Configuration' started by sBuchi, Apr 10, 2012.

  1. sBuchi

    sBuchi New Member

    Hi

    I`ve installed a ISPConfig3 single-server setup.
    I configured everything as it was described in the manual.

    But when i create a dns-zone, i can't connect to it with "NSLookup"

    I created the dns zone "test12.at" with an A-record "www"

    This is the answer from my NSLookup:

    Query:All records (ALL):test12.at
    Query refused due to local policy
    Complete:NO_DATA test12.at

    Query:All records (ALL):www.test12.at
    Query refused due to local policy
    Complete:NO_DATA www.test12.at

    Query:Address (A):www.test12.at
    Query refused due to local policy
    Complete:NO_DATA www.test12.at


    What can i do that it works?
     
  2. falko

    falko Super Moderator

    Do

    Code:
    dig @localhost test12.at
    and
    Code:
    dig @localhost www.test12.at
    work?
     
  3. sBuchi

    sBuchi New Member

    dig @localhost test1.at


    ; <<>> DiG 9.7.3 <<>> @localhost test1.at
    ; (1 server found)
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 7966
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;test1.at. IN A

    ;; AUTHORITY SECTION:
    at. 10800 IN SOA dns.nic.at. domain-admin.univie.ac.at. 1334217600 10800 3600 604800 10800

    ;; Query time: 62 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Thu Apr 12 11:17:28 2012
    ;; MSG SIZE rcvd: 93

    dig @localhost www.test1.at


    ; <<>> DiG 9.7.3 <<>> @localhost www.test1.at
    ; (1 server found)
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 36544
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;www.test1.at. IN A

    ;; AUTHORITY SECTION:
    at. 10800 IN SOA dns.nic.at. domain-admin.univie.ac.at. 1334217600 10800 3600 604800 10800

    ;; Query time: 27 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Thu Apr 12 11:19:46 2012
    ;; MSG SIZE rcvd: 97

    - - - - - -
    xxx.xxx.35.176 is the server where i have installed the singleserver-setup. When i try it via remote from an other server, i get these two following answers:

    root@node172:~# dig @xxx.xxx.35.176 test1.at

    ; <<>> DiG 9.7.3 <<>> @xxx.xxx.35.176 test1.at
    ; (1 server found)
    ;; global options: +cmd
    ;; connection timed out; no servers could be reached


    root@node172:~# dig @xxx.xxx.35.176 www.test1.at

    ; <<>> DiG 9.7.3 <<>> @xxx.xxx.35.176 www.test1.at
    ; (1 server found)
    ;; global options: +cmd
    ;; connection timed out; no servers could be reached
     
  4. Ben

    Ben HowtoForge Supporter

    Well did you check if your dns server is working properly on the local host as "NXDOMAIN" in your dig output indicates, that it did not find anything.

    Regarding the ouput from the internet, did you check if the dns service is reachable from outside? (Firewall / ACL of bind blocking the access, bind listening on the localhost interface, only, check with netstat -tap)
     
  5. nowhere

    nowhere HowtoForge Supporter

    Problem solved

    Hi, I am also working on this installation.

    node174 is a member of a 4 server installation with ISPConfig.
    node174 is a DNS Server only
    host120 is the second DNS Server


    root@node174:~# netstat -tap | grep domain
    tcp 0 0 node174.domain.tld:domain *:* LISTEN 26926/named
    tcp 0 0 localhost:domain *:* LISTEN 26926/named
    tcp 0 0 node174.domain.tld:domain node174.domain.tld:43194 TIME_WAIT -
    root@node174:~#
    root@node174:~# telnet node174.domain.tld 53
    Trying xxx.xxx.35.174...
    Connected to node174.domain.tld.
    Escape character is '^]'.
    Connection closed by foreign host.
    root@node174:~#

    So, bind is up and running.
    If I look at /etc/bind there are all files, zone files and so on.
    If I create a new zone at ISPConfig the zone file will also created at the /etc/bind directory.
    The named.conf.local file contains all zones which are activated at ISPConfig

    f.e.

    zone "test.at" {
    type master;
    allow-transfer {none;};
    file "/etc/bind/pri.test.at";
    } ;


    root@node174:/etc/bind# /etc/init.d/bind9 status
    bind9 is running.
    root@node174:/etc/bind#

    root@node174:/etc/bind# named-checkconf /etc/bind/named.conf
    root@node174:/etc/bind#

    -> no error

    After them I checked if the zone files are OK:
    named-checkzone localhost /etc/bind/pri.domain.tld

    There are some "ignoring out-of-zone data" messages.
    After them I deleted all zones and created them from the scratch.

    Now, for the first view it looks like that it works.

    Thank you for your support
     

Share This Page