DNS zone and subdomain with Joomla, Drupal, Wordpress

Discussion in 'Installation/Configuration' started by emanation, Sep 13, 2011.

  1. emanation

    emanation New Member

    Hello.
    I've read Manual and overview related topics at forum and I can't understans one minor thing which make major problem.

    Lets say that I have Joomla installed at Website and another Joomla at subdomain: www.joomlaproduct,com and demo.joomladroduct.com. Both are created as website. Below I mean in subdomain the address which looks like subdomain just.

    At domain registrant I have personal name server records like ns1.joomladroduct.com and ns2.joomladroduct.com

    It's obivious that DNS zone for mail website should be:
    Code:
    A 	demo 			191.192.193.194 	0 	
    A  	mail 			191.192.193.194 	0 	
    A  	joomlaproduct.com. 	191.192.193.194		0 	
    A  	ns1 			191.192.193.194 	0 	
    A  	ns2 			191.192.193.194 	0 	
    A  	www 			191.192.193.194 	0 	
    CNAME 	ftp.joomlaproduct.com. 	joomlaproduct.com. 	0 	
    MX  	joomlaproduct.com. 	mail.joomlaproduct.com. 10 	
    NS  	joomlaproduct.com. 	ns1.joomlaproduct.com. 	0 	
    NS  	joomlaproduct.com. 	ns2.joomlaproduct.com. 	0 	
    TXT	joomlaproduct.com. 	v=spf1 +a +mx -all 	0
    
    but what should be at Subdomain DNS zone? I guessed the same, but after reading forum I'm confused with next settings as idea

    Code:
    A 	demo.joomlaproduct.com. 	191.192.193.194 		0 	
    A 	ns1				191.192.193.194 		0 	
    A 	ns2				191.192.193.194 		0 	
    CNAME 	ftp.demo.joomlaproduct.com. 	demo.joomlaproduct.com. 	0 	
    MX 	demo.joomlaproduct.com. 	mail.demo.joomlaproduct.com. 	10 	
    NS 	demo.joomlaproduct.com. 	ns.demo.joomlaproduct.com. 	0 	
    NS 	ns1				ns1.demo.joomlaproduct.com. 	0 	
    NS 	ns2				ns2.demo.joomlaproduct.com. 	0 	
    TXT 	demo.joomlaproduct.com. 	v=spf1 +a +mx -all		0
    
    but in fact I don't need MX, TXT records for subdomain, but CNAME ftp must be because there separate FTP user. Though it's not necessary because connection could be established by IP

    Of cause I mean in subdomain separate website which just looks like subdomain.

    Please, help me to find the truth.
    Thanks.
     
    Last edited: Sep 14, 2011
  2. falko

    falko Super Moderator ISPConfig Developer

    You cannot create a zone for a subdomain. You have to create all records in the zone for the main domain, and as far as I can see, that zone looks fine.
     
  3. emanation

    emanation New Member

    Redirect loop

    Hello.
    Thanks for conclusion.
    You are right, now everything works good except Redirect Loop for demo.joomlaproduct.com
    Though as you know Joomla has administrator subfolder for Back-End. I can open it by demo.joomlaproduct.com/administrator
    But demo.joomlaproduct.com brings Redirect Loop. And .htaccess rules don't affect to it. Checked by removing .htaccess for testing result.

    Also From Manual I see that domain.vhost files could solve. But I don't imagine how exact
    Could you give a hint about that.

    Perhaps is happen because httpd- S gives me
    Code:
    *:80                   is a NameVirtualHost
             default server demo.joomlaproduct.com (/etc/httpd/conf/sites-enabled/demo.joomlaproduct.com.vhost:7)
             port 80 namevhost demo.joomlaproduct.com (/etc/httpd/conf/sites-enabled/demo.joomlaproduct.com.vhost:7)
             port 80 namevhost demo.wordpressproduct.com (/etc/httpd/conf/sites-enabled/demo.wordpressproduct.com.vhost:7)
             port 80 namevhost joomlaproduct.com (/etc/httpd/conf/sites-enabled/joomlaproduct.com.vhost:7)
             port 80 namevhost wordpressproduct.com (/etc/httpd/conf/sites-enabled/wordpressproduct.com.vhost:7)
    
    Where an I change default server?
    Thanks.
     
    Last edited: Sep 14, 2011
  4. emanation

    emanation New Member

    in fact I was wrong. demo.joomlaproduct.com is not opening from other PCs because address is not found.
    Now I have this and it doesn't solve my problem.
    Code:
    A 	demo 			191.192.193.194 	0 	
    A 	mail 			191.192.193.194 	0 	
    A 	joomlaproduct.com. 	191.192.193.194 	0 	
    A 	ns1 			191.192.193.194 	0 	
    A 	ns2 			191.192.193.194 	0 	
    A 	support 		44.55.66.77 	0 	
    A 	www 			191.192.193.194 	0 	
    CNAME 	ftp.joomlaproduct.com. 	joomlaproduct.com. 	0 	
    MX 	joomlaproduct.com. 	mail.joomlaproduct.com. 	10 	
    NS 	demo 			ns1.joomlaproduct.com 	0 	
    NS 	demo 			ns2.joomlaproduct.com 	0 	
    NS 	demo.joomlaproduct.com. ns2.joomlaproduct.com. 	0 	
    NS 	demo.joomlaproduct.com. ns1.joomlaproduct.com. 	0 	
    NS 	joomlaproduct.com. 	ns1.joomlaproduct.com. 	0 	
    NS 	joomlaproduct.com. 	ns2.joomlaproduct.com. 	0
    
    what is wrong?

    BTW record "A support 44.55.66.77 0" works perfect. That request should be redirected to other server.
     
  5. falko

    falko Super Moderator ISPConfig Developer

    You just need these two NS records:

    Code:
    NS 	joomlaproduct.com. 	ns1.joomlaproduct.com. 	0 	
    NS 	joomlaproduct.com. 	ns2.joomlaproduct.com. 	0
    Please delete the other ones.
     
  6. emanation

    emanation New Member

    hello.
    Yes, I've got it. I had problem before because named (BIND) service. For some reason it was stopped.
    Redirect also solved because it was Joomla issue.
    Now I have problem that after several hours IPSConfig panel could not be opened. If I reboot server it works again. I can't understand what is depence of that issue. But it happens regularly.
     
  7. falko

    falko Super Moderator ISPConfig Developer

    Do you use something like fail2ban that could lock you out? Or maybe it's a problem with your RAM?
     

Share This Page